Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get clonezilla to run off of a usb stick, and it seems that the right way to do that is via tuxboot.

Tuxboot is not compilable on ubuntu. I used git to get it from the repository, and then when I run the 'install' script (because building it is apparently not allowed, since the build script just tries to install windows things). Qmake-linux wants my qmake executable to be in the same directory as the stuff I pulled down, and let's just say that if there's a way to do this easily, I ain't seein' it.

So then I download the linux file, the most recent of which is tuxboot-linux-25. Try to run it, get a failure that libpng12.so.0 isn't found. OK, then I go to install that via the instructions I found on the web but firefox seems to have already deleted from my history (yay!)

Then I add the /usr/local/lib directory to ldconfig via emacs (had to install that too, of course):

http://ubuntuforums.org/showthread.php?t=369848

I still get the errors that libpng12.so.0 cannot be opened because 'No such file or directory'. ldconfig -p | grep libpng shows that the library is there, but it still doesn't seem to be findable. What to do next?

(for the record, doing this in windows is painless-- download, click, and it's done. But I'm trying to be all linuxy and get away from Windows for this...)

share|improve this question
add comment

2 Answers

I just downloaded tuxboot myself and had no problem to get it running in Ubuntu 10.04. You do not need to build it from source, you can download the *.bin file from the homepage.

After that, open a terminal and navigate to the folder where tuxboot is, in my case this was ~/Downloads. Execute it with:

sudo chmod +x tuxboot-linux-25-64bit

Replace tuxboot-linux-25-64bit with the appropriate file name in case of different version (like 32-bit). After that run it with:

./tuxboot-linux-25-64bit
share|improve this answer
    
Yeah. The problem there is that the libpng12.so isn't found in 11.10. Could this be a difference in the Ubuntu versions? I'm not building tuxboot from source, I'm building libpng from source. –  mmr Jun 27 '11 at 13:38
    
Could be a version thing, sure. I literally just did what I wrote in my answer and it worked. I misunderstood, however, and thought you are not using the pre-build package –  Martin H Jun 27 '11 at 14:31
add comment

You can easily install tuxboot from the ppa:thomas.tsai/ubuntu-tuxboot PPA. Thus you don't need to compile it or to use the pre-compiled binaries from the project website.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.