Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For two days I have tried to get vlc play this .bin file. I played it fine in windows xp using vlc. So I decided to install same vlc thats on my xp partition and it plays through Wine the file no problem. Why won't it play natively?

fr33bird@fr33bird-desktop:~/Downloads/********/*********$ vlc ********.bin
VLC media player 1.1.10 The Luggage (revision exported)
Blocked: call to unsetenv("DBUS_ACTIVATION_ADDRESS")
Blocked: call to unsetenv("DBUS_ACTIVATION_BUS_TYPE")
[0x8387914] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Blocked: call to setlocale(6, "")
Warning: call to srand(1309627174)
Warning: call to rand()
Blocked: call to setlocale(6, "")

(process:14474): Gtk-WARNING **: Locale not supported by C library.
    Using the fallback 'C' locale.
Blocked: call to setlocale(6, "")
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Can't stat /home/fr33bird/Downloads/*******/*******/*******.bin
No such file or directory
libdvdnav: vm: failed to open/read the DVD
[0x87034e4] filesystem access error: cannot open file /home/fr33bird/Downloads/*****/*****/*******.bin (No such file or directory)
[0x843535c] main input error: open of `file:///home/fr33bird/Downloads/******/****/********.bin' failed: (null)

Funny it says no such file even thou it's attempting to read it. Xine says that the .bin is encrypted so I installed libdvdcss2 w32codecs ubuntu-restricted-codecs from Medibuntu still same issue. How can I fix this? I want to run this natively not through wine. I Even tried to change .bin to .mpg and .avi.

Updated 6-26-2011 Even thou this issue didn't have anything to do with Alsa Audio Output this allows me to play .bin files

alsa doesn't won't in vlc

share|improve this question
Ubuntu does not care about file extensions. So renaming a file really doesn't make anything better ;). Check what mime type your file has using file <file>. – dAnjou Jun 24 '11 at 8:38
You should not use special characters like asterisks in file/path names ;-) SCNR – bjoernz Jun 24 '11 at 11:56

Have you tried removing Xine and installing Gstreamer codecs for ubuntu? Personally, I prefer gstreamer over xine as it has always had better/smoother playback in ubuntu.

share|improve this answer
I already have gstreamer installed all 4 or 5 of them in ubuntu software center. Althou i did Remove xine still no go same issue – freebird Jun 24 '11 at 4:18
This is more of a workaround than a solution and I can't personally test this as I don't have any BIN files to try this out on, but you can try this workaround found on the archive posts ( (1) rename .bin to .mpg (2) if you get no sound than switch over the audio track to Track 2 [right click on the video "Audio"-> "Audio Track"] – 13east Jun 24 '11 at 16:44
No go bro but thanks i had already tried that before i posted but thanks for trying to help bro. – freebird Jun 27 '11 at 0:35

I read "No such file or directory", so the problem is not vlc, but probably something like the interface between the shell and the program: there are spaces in the name of the file, or some other strange characters? If so, begin trying to put the file name between double quotes, or better single quotes:

vlc 'long file name.bin'
share|improve this answer
I thought so to before i posted i had also renamed with no spaces or - . So now its labels like <code> 1986somefile.bin have also tried 1986somefile.mpg </code> and also tried without numbers. tyhanks for trying but i still have same issue. I can play it from gui and get no video and sound is very choppy. – freebird Jun 27 '11 at 0:31
up vote 0 down vote accepted

Updated 6-26-2011 Even thou this issue didn't have anything to do with Alsa Audio Output this allows me to play .bin files

Alsa doesn't work in vlc

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.