Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I followed the instructions here, however I got 404 not found error checking for updates:

W:Failed to fetch http://ppa.launchpad.net/ubuntugnometeam/gnome3/ubuntu/dists/natty/main/source/Sources 404 Not Found, W:Failed to fetch http://ppa.launchpad.net/ubuntugnometeam/gnome3/ubuntu/dists/natty/main/binary-i386/Packages 404 Not Found, E:Some index files failed to download. They have been ignored, or old ones used instead. ,

Thus I couldn't even start the installation. Anybody know how to perform a full installation?

Now got new error:

W:Failed to fetch http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/dists/natty/main/i18n/Translation-en  Connection failed, E:Some index files failed to download. They have been ignored, or old ones used instead.

And these are all the files in sources.list.d:

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You seem to have added the wrong PPA, the instructions state that the PPA is ppa:gnome3-team/gnome3, the PPA you're getting errors for is some other PPA run by someone else.

You can remove bad sources by following the instructions here:

From your file list I see that you have gnome3-team-gnome3-natty.list, this is where the bad URL is. You'll want to remove that file and then follow the linked directions for the right instructions to add the PPA.

share|improve this answer
I'm sure that I added ppa:gnome3-team/gnome3 and the URLs in the software sources are same as those in the instruction, quite strange –  littne Jun 23 '11 at 16:02
Did you add those also on top of adding the other ones? That would also cause the error. –  Jorge Castro Jun 23 '11 at 16:13
What do you mean by those also on top of adding the other ones? –  littne Jun 24 '11 at 3:58
I tried the Command line Instructions and the first 2 lines worked fine, but when doing the dist-upgrade, the download speed was really really slow... less than 1kb/s... –  littne Jun 24 '11 at 7:49
@littne Please post the contents of the files in /etc/apt/sources.list.d/ in your question so we can see the files. –  Jorge Castro Jun 24 '11 at 10:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.