Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got Microsoft Sculpt Ergonomic Desktop (keyboard+mouse). It's a nice set but it creates problems for me as one of its parts in the system is a virtual joystick js0.

jstest-gtk screenshot

I've got an advice to use udev rules and I've tried disabling it with udev in different ways, but i've failed:

ACTION=="add", SUBSYSTEM=="input", BUS="usb", ID_PATH="pci-0000:00:1d.0-usb-0:1.5:1.2" OPTIONS+="ignore_device"

ACTION=="add", SUBSYSTEMS=="input", ATTR{idmodel}=="Microsoft®_2.4GHz_Transceiver_v9.0" RUN+="/bin/sh -c 'for host in /sys/bus/usb/devices/usb*; do echo 0 > $host/authorized_default; done'"

ACTION=="add", ATTR{idVendor}=="045e", ATTR{idProduct}=="07a5", RUN+="/bin/sh -c 'echo 1 >/sys/\$devpath/authorized'"

Here are the outputs:

$ udevadm info /dev/input/js0

$ udevadm info --attribute-walk /dev/input/js0

$ udevadm monitor (remove/add)

Please help me to remove this virtual joystick, it looks like I can't manage to do it with udev.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.