Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have a CIFS mount that's being mounted in fstab and looks like this:

// /home/pi/sambashare cifs credentials=/.credentials/.smbcredentials,rw,iocharset=utf8,nounix,file_mode=0777,dir_mode=0777 0 0

It works fine, with the exception that all of the folder permissions have the sticky bit on. I run a few programs as different users, so need to be able to have rw access to all the folders as different users, but the sticky bit is preventing me from making changes as the other users.

Have tried mounting with GID and UID also, but:

  1. User is always libuuid and group is always 1002 regardless of what GID and UID says
  2. I have different users that need access.

Any idea how to resolve this?

share|improve this question
are you sure it is an "s" (=sticky bit) and not an "S" (sgid bit=mandatory locking)? ;-) – Rinzwind Jan 31 at 15:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.