Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 13.04, and would like to upgrade to 14.04.

Entering the following commands gives me output indicating that it cannot be done.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 13.04
Release:    13.04
Codename:   raring
$ sudo do-release-upgrade 
Checking for a new Ubuntu release
No new release found

How can this be done?

(I have the ISO file for 14.04 too, if that makes a difference)


Update:

As per the sugestion below, I tried this, to no avail?

$ sudo do-release-upgrade -d
Checking for a new Ubuntu release
No new release found

Update:

Further investigation revealed that updates were not working too.

$ sudo apt-get update
# truncated
E: Some index files failed to download. They have been ignored, or old ones used instead.

Are there any software sources that still host raring (13.04)?


Update:

Editing the software sources to point to old-releases.ubuntu.com worked, enabling

sudo apt-get update && sudo apt-get dist-upgrade

To run as expected. However,

sudo do-release-upgrade -d

still yields the same result:

Checking for a new Ubuntu release
No new release found
share|improve this question

closed as off-topic by karel, Braiam, Jacob Vlijm, Luis Alvarado Jul 24 at 22:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1  
1. 13.04 is end of life. 2. You can NOT upgrade from 13.04 to 14.04. There is no skipping releases when upgrading. I would suggest a re-install (it's a lot quicker) –  Rinzwind Jul 24 at 11:57
    
Weren't you asked to upgrade to 13.10 when it came out? –  Thorbjørn Ravn Andersen Jul 24 at 14:06
    
@Rinzwind actually, there is (was?) a way, but was disabled when 13.X and 12.10 went EOL. –  Braiam Jul 24 at 14:44

1 Answer 1

You are running Ubuntu 13.04. Ubuntu 13.04 has reached it's end of life support on January 27th, 2014, so you will not be able to do install/upgrade anything right now, that's why your apt-get update command is not working.

You should know that if you want to upgrade to 14.04, you have to follow the following upgrade order: 13.04 → 13.10 → 14.04.

  1. You first need to edit your sources to use the "old releases" repositories. You can do this by running the following command:

    sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
    
  2. Now, run the following:

    sudo apt-get update && sudo apt-get dist-upgrade
    

    This will upgrade all the packages to the latest available versions.

  3. Now, try the Ubuntu upgrade:

    sudo do-release-upgrade -d
    

    This should work and prompt you to upgrade to 13.10. Do the upgrade, and then go through the same steps again to upgrade from 13.10 to 14.04.

In my opinion, it's just easier to do a fresh install of 14.04 using the ISO file you have, if you know how to do that, that is, and that there's not much data to backup.

share|improve this answer
1  
Looks good. I too would re-install and go straight for 14.04. 13.04->13.10->14.04 takes a while (as in hours) and has 2 points of failures. A re-install does not imply formatting personal data: those files should already be on a sep. partition; if not I would start arranging that 1st). –  Rinzwind Jul 24 at 12:12
    
Yeah I know =D, I was updating my answer as you were typing the comment. I always go for a fresh install anyways, but the poster might not know how to do a fresh install or a fresh install might not be so easy, especially if he's dual-booting and/or mounting /home on a different partition, because that would mean using the "Something else" option during installation, so I just wanted to mention the option of using the old-releases. –  Alaa Ali Jul 24 at 12:15
    
@AlaaAli Thanks for your answer, however this does not work for me. Changing software sources to point to old-releases.ubuntu.com worked, in that I was now able to successfully run sudo apt-get update && sudo apt-get dist-upgrade. However, sudo do-release-upgrade -d still yields the same result: No new release found –  bguiz Jul 25 at 13:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.