Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First of all I want to boot Windows only, I'm not having a duel-boot problem

I want to install Ubuntu on my Laptop after Windows has really become slow and even the live CD boots faster, the main problem is that my parents use my laptop and they wouldn't know what to do at the GRUB screen. I know how to set up GRUB on my flash drive but I still have the problem that Ubuntu is likely to boot instead of Windows, any help?

If it helps, I am running Windows 7 32-bit and I want to install Ubuntu 12.04 as it seems that 14.04 live CD doesn't boot on my laptop, I only have one hard drive installed with 2 partitions (3 when I've installed Ubuntu).

share|improve this question
up vote 2 down vote accepted

Setup grub to boot into windows by default, with a 10 second time-out. The you can choose Ubuntu, but if your parents just wait out the 10 seconds, it will boot into Windows.

A good editor for grub is grub-customizer, which you can et from a launchpad ppa

After installation of Ubuntu, open a terminal window ctrl+alt+t and enter the commands

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

Then you can open the dash, and type 'grub' which will locate the program for you. You will need to change the general settings, so that the "default entry" points to the windows boot, and change the timeout to a desired amount of time.

enter image description here

share|improve this answer
I'll try the customiser after I install Ubuntu, hopefully it works – 2haloes Jul 23 '14 at 14:42
first try install boot-repair before grub-customizer and repair your Windows Boot Chain – swift Jul 23 '14 at 14:54
My laptop seems to autoboot into Win 7 anyway, I'll just install GRUB onto my flash drive. Thanks anyway – 2haloes Jul 23 '14 at 17:14
  1. Boot from your Live CD (choose Try Ubuntu option).
  2. Open Terminal
  3. Type: sudo apt-get install boot-repair && boot-repair press Enter.
  4. Repair your GRUB with Recommended configuration.
  5. Reboot.

  6. If Windows boot > your BIOS HDD chain is WRONG. Try to change order to boot from right MBR.

  7. Though (!) after boot-repair you should to have right MBR at all HDD and maybe you will need a little fix Windows chainloader, but from Ubuntu already.

That's all.

share|improve this answer
I want it to boot to windows, I can get GRUB onto a flash drive and select it when my laptop boots – 2haloes Jul 23 '14 at 15:27
this is the way really indifferently where you want to have your GRUB, but if your Windows7 boot without "pit-stop" the suggest for customizer just absurdly stupid. Where you want to install customizer? Under the Windows or it is a joking trolling? And if you do not have dual-boot bugs too .. )) Really bizarre. – swift Jul 24 '14 at 10:09

I had a somehow similar problem. After installing ubuntu side-by-side with windows 8, it always booted straight into windows.

My solution: Even though I installed ubuntu with bios-boot-setting UEFI, I can now boot ubuntu by setting bios-boot-setting back to legacy. For booting windows I set it to UEFI.

Of course, entering the bios each time I want to boot the other OS is a bit unlovely, but at least it is workng this way.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.