Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Once I use an external CRT display (explicitly disabling it before shutting down does not help) with my laptop, then when I next start my laptop without any external display attached, mouse cursor is invisible (but works, i still can click buttons, but can't track where the cursor is now). How to fix this?

I use Ubuntu (classic Gnome version) 10.10 on Toshiba L10 with Intel 82852/855GM graphics. When I was using Arch Linux with XFCE, there used to be the same problem.

I've tried disabling Metacity's (and XFWM in past) composition, explicitly disabling external monitor, changing mouse cursor, updating drivers several times, nothing seems to help, I always have to have an external monitor attached (I may disable it, but it has to be attached) at boot time if I want to see my mouse cursor.

share|improve this question

1 Answer 1

The workaround that I have used is switching to a TTY (Ctrl+Alt+F1 - Ctrl+Alt+F6) and switching back to the desktop (Ctrl+Alt+F7).

share|improve this answer
    
Thanks, I'll try this. –  Ivan Oct 3 '10 at 20:55
    
I've tried. Doesn't work. Ctrl+F1..F4 and Ctrl+F7 do nothing. Ctrl+F5 closes all the web pages opened, Ctrl+F6 selects the whole URL in the address bar. Obviously, these keys are processed by current active application and are not meant to control X. Alt+F# keys don't do anything useful either. –  Ivan Oct 7 '10 at 11:15
    
Oops. I left the wrong shortcut. Add "Alt" to the shortcuts. –  JasonCook599 Oct 7 '10 at 21:01
    
This does not help anyway :-( After switching to TTY and back to the desktop a mouse cursor is still invisible. –  Ivan Nov 5 '10 at 21:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.