Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It has been a headache trying to install this printer. All the tutorials I found are for older versions of Ubuntu, and none of them work.

How can I install this printer?

Edit: HOWTO: Install PITA Lexmark Z600 Z615 and Dell Photo Printer 720

Setup Lexmark Z600 and X series printer on Ubuntu (i tried this one, only that it was translated to spanish, but it was the same instructions)

HOWTO: Lexmark Printers

I always get an error when extracting the converted tars with all of the tuts, invalid argument or the file doesn't exist.

Looks like, i was missing some ia32 libs .. and that caused the errors with the tar files, anyways i still can't print now i get this, cups-insecure-filter

How to install Lezmark Z600 series printer

Here, the OP offers 2 debs, i installed them on a 32 bit Ubuntu install, now the printer gets recognized but still can't print, 'cause i'm missing a filter, "rastertoz600".

share|improve this question
2  
Is there anything special to this printer except the fact that you already have it? Lexmark printers have always been a pain to use with Linux and there's no indication that this will change. New printers are available for chump change and most of them will match your printer's specification. E.g. this one h10010.www1.hp.com/wwpc/sg/en/ho/WF06b/… , availabe for ~30 USD. If you're not doing this out of morbid curiosity but actually want to get printing ASAP, I'd consider a new printer with better Linux support. –  nem75 Jun 23 '11 at 12:00
    
can you add to your question which tutorial you've tried - for example, have you tried this one? finebushpeople.net/LexmarkZ600 –  fossfreedom Jun 23 '11 at 12:08
    
@fossfreedom ok i'll add which tutorials i've read. –  Uri Herrera Jun 23 '11 at 15:56
1  
try this thread for your insecure filter error - ubuntuforums.org/showthread.php?t=1313291 –  fossfreedom Jun 23 '11 at 18:36
1  
@Uri Herrera: I hear you, but as I said ... 30 bucks ... well, to each his own. All the best with your efforts. :) –  nem75 Jun 23 '11 at 22:14

2 Answers 2

up vote 4 down vote accepted

HOWTO: Lexmark Printers Page 69 post 68 by VietCanada this worked!.

  1. install libstdc++5 from synaptic.
  2. install getlibs-all.deb.
  3. install lexmark.z600-0.4.deb.
  4. go to System/Administration/Printing.
  5. choose Lexmark z600 printer

Only seems to work for 64 bit though, on a 32 bit Ubuntu 11.04 Install, the package lexmark.z600-0.4.deb can't be installed due to a missing dependency libcupsys2 which i can't install.

share|improve this answer
    
The getlibs-all.deb link 404s! However I managed to install the lexmark.z600-0.4.deb on 32bit and everything worked for me :) –  Annan Mar 25 '12 at 15:59
    
Yeah, the host doesn't exist anymore I just updated the Link though, but glad it worked without it. –  Uri Herrera Mar 25 '12 at 18:12

These steps just worked for me on Ubuntu 12.04, 32-bit with a very old Lexmark X1180 printer/scanner (I only want to print BTW).

1) Install libstdc++5 from synaptic.

2) Remove existing z600xxxx packages from synaptic (I think I had previously tried to install an older version of the z600 drivers)

3) Install lexmark.z600-0.4.deb.

4) Insert USB cable to printer.

5) Go to Printing via Ubuntu search.

6) Added new printer, chose the connected printer, then selected Lexmark manufacturer and right at the bottom the z600 driver from the installed package appeared in the list.

Mark

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.