Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I want to run my web application in the local lxc provider using juju.my web application is maven build application. So I create my charm and try to run it locally. In hooks I have installed java and maven for bulding web application. After downloading all the required (java,maven) it failed in start script in hooks. Install script is fine. This is the start script can anyone tell me how to fix this issue ?

#!/bin/bash
set -e
SDK_HOME=/home/ubuntu/application/samples/maven_sampleapp
cd $SDK_HOME
mvn clean install jetty:run

This is the error I got when Compile application.

error: annotations are not supported in -source 1.3
error: generics are not supported in -source 1.3
variable-arity methods are not supported in -source 1.3
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The error messages say you need to use a newer version of Java.

share|improve this answer
    
I got the point.But i check the java version and mvn version in juju lxc provider virtual machine it says java 1.7 and maven 3.0.4.In install script i have installed java and maven. it is fine. –  Sajith4U Jul 23 at 8:30
    
I fixed the issue i have to put maven java compiler in to pom.xml file.thanks –  Sajith4U Jul 23 at 9:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.