Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 LTS with all updates.

At some point I experienced some trouble with LightDm, so after reading up on AskUbuntu I switched to GDM. No problems, except that I cannot get GDM to start automatically.

Current situation:

  • Whenever my system boots, I am shown a CLI/text-mode console.

  • I can log in just fine.

  • Running "sudo start gdm" gets my graphical interface up and everything works smoothly.

Question:

How can I have GDM start automatically?

The permissions on /etc/init.d/gdm are

lrwxrwxrwx 1 root root 21 Jan  7  2014 /etc/init.d/gdm

What I have tried:

1- Following mchid's suggestion, I tried running

sudo dpkg-reconfigure gdm

It executes without any error message / prompt but, upon rebooting, the problem persists: I am again at a text prompt.

2- Following this thread, I tried to run

sudo apt-get install -f -m --reinstall -u gdm

but nothing happens:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reinstallation of gdm is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
share|improve this question
    
did you run dpkg-reconfigure gdm already? –  mchid Jul 23 at 8:46
    
@mchid, I just tried that and rebooted: unfortunately the problem persists. I have ammended the question to add this information. –  lara michaels Jul 24 at 13:57
    
Might have a look at this thread and see if any of this helps. I had something similar in 13.10, but have not got it fixed yet. askubuntu.com/questions/471593/… –  Bert Fegg Jul 30 at 21:27
    
@BertFegg thank you for the link, unfortunately the tips about editing /etc/profile don't seem to apply: I found neither of the offending lines mentioned on that thread in my system's /etc/profile... Is there a way for me to force gdm to be reinstalled from scratch? As mentioned above, running "sudo apt-get install -f -m --reinstall -u gdm" doesn't really do anything. –  lara michaels Jul 31 at 21:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.