Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I set a solid color as desktop background (like black), which I like far better, then the login screen shows the default purplish picture (warty-final-ubuntu.png). How to I make it also show a simple black screen?

Btw, I educated myself about lightdm settings and access rights to pictures in /usr/share/backgrounds, so I specifically ask for an answer that does not involve any picture files, since I want a simple, single color, no gradient.

In response to first comment, I think I still need more specific knowledge about lightdm.

First of all, im using Ubuntu 14.04 and the configuration files I am looking at are in this directory:

/usr/share/lightdm/lightdm.conf.d/

Is it supposed to work in a way that all these files are always read, when lightdm starts (maybe in lexical order)? Is there something else I would have to look at? I specifically tried setting this:

background='#000000'

but it had no effect whatsoever (still showing warty-final-ubuntu.png), that's why I came here.

Edit: @kenn Actually, in my case that file does not exist.

thomas@thomas-laptop:~$ ls /etc/lightdm/
users.conf
share|improve this question
    
have you tried setting the background in dconf-tools to a file that does not exist so that there would be nothing displayed ( black )? –  mchid Jul 22 at 23:09
1  
Easiest option might be to create a black image yourself and use that(?) –  Rinzwind Jul 23 at 11:58
    
which greeter do you use? output of cat /etc/lightdm/lightdm.conf | grep ^greeter-session= –  kenn Jul 23 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.