Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Firefox spellchecker was complaining this morning that I spelled 'neighbor' in the American English style, not the British English style ('neighbour'). Same is true for color (colour), analyze (analyse), etc. I've checked in the edit->preferences->content->language tab, and en-us is selected. I also found this link here:

http://ubuntuforums.org/showthread.php?t=1013043

Suggesting that there's some kind of system panel I can use to ensure that I've got the right language, but I can't see where that is (I guess that's for an older Ubuntu that let people get to system settings).

So either the dictionary for Firefox for en-us is corrupted, just a copy of the British English dictionary, or somehow the setting isn't propagated properly. How can I get the American dictionary back?

share|improve this question

4 Answers 4

up vote 12 down vote accepted
  1. In a text field, open a context menu by pressing the right mousebutton.
  2. Select Check Spelling if needed
  3. In the Languages menu, select English / United States

Firefox spellchecker

If this did not work, (re-)install the hunspell-en-us package.

share|improve this answer
    
Thanks, that got it! Any way to keep all of these things in sync? –  mmr Jun 23 '11 at 18:24
5  
Did you mean limiting the list size? I didn't like having all different kinds of English in my list, so I removed Australia, Canada and South Africa by removing the links pointing to it: sudo rm /usr/share/hunspell/{en_AU,en-AU,en_ZA,en_CA}.{dic,aff} You can navigate to /usr/share/hunspell to find other dictionaries. If you mess it up, just install the related hunspell-* package. –  Lekensteyn Jun 23 '11 at 19:09
1  
I mean, how many different spelling dictionaries are there, and how can I make sure that they all point to the right place? It's clear that the firefox selection doesn't influence what's written in firefox. Or is this selection going to be reflected everywhere else, at least in theory? –  mmr Jun 23 '11 at 19:22
    
If you meant that selecting one of the multiple entries do not work, I don't know. I try to ignore that and select the other entry. Perhaps the bug is already filed. –  Lekensteyn Jun 23 '11 at 19:58
    
@lekensteyn, I think mmr is asking how to change the dictionary across many applications, so that all software (not just Firefox, but LibreOffice, too) use the same dictionary. –  Amanda Jan 22 '12 at 20:26

For Firefox, put "about:config" in the address bar and go there. Search for "spell", and find the variable "spellchecker.dictionary". If its value is something other than "en_US" (mine said "en_AU"), right click the entry and modify the value to "en_US".

share|improve this answer
    
This worked for me, and it seems to have persisted through a Firefox restart because "color" is not bringing up a suggestion for "colour". –  Chad Mar 29 at 22:28

There are multiple bugs in Ubuntu that are tracing back to Mozilla: Firefox is not following the system locale setting. Consider posting a sighting to https://bugzilla.mozilla.org/show_bug.cgi?id=776028.

share|improve this answer

I had ongoing problems with Firefox "jumping" from one dictionary to another. To fix it, I run this command after each Ubuntu install:

sudo rm /usr/share/hunspell/{en_GB,en_AU,en_ZA,en_CA}.{dic,aff}

Obviously, this can be edited for any dictionary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.