Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I enabled the proposed repository in a fresh install with the proprietary nvidia-173 driver. After the reboot, I noticed that minimizing and maximizing, there were none of the expected effect (using Ubuntu Classic, even with proprietary driver, Unity does not work - another issue). Furthermore I confirmed by trying to switch workspaces using keyboard shortcuts, and the square desktop wall was replaced by horizontally lined workspaces of Metacity.

Of course, the upgraded Compiz could be responsible, but I can't figure out what to do - please advice. Additionally, if it's an issue with the softwares from proposed repo, how and what do I do to notify the developers of the issue?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If you start the 'Additional Drivers' application do you see that the 173 driver is activated and in use? The image below shows the Nvidia graphics driver as being activated, but not in use.

Let's assume that your video driver is installed and functioning correctly, are you suggesting in your question that you want to switch from Metacity to Compiz? If this is the case, have you tried CTRL+F2 with the following command:

compiz --replace

To check if everything is up to snuff to run Compiz, I will use the code here. Please let me know if I have misunderstood what you are asking.

share|improve this answer
    
Yes it is activated. (Sorry for late reply but for some reason, I am not being notified of anything) Compiz used to work with my fresh install and proprietary driver, but after upgrading from proposed repo, Metacity is use. I'll use that command now, dunno why I didn't that of that. –  Oxwivi Jun 26 '11 at 18:27
    
... The command did the trick... seriously, I'm an idiot. –  Oxwivi Jun 26 '11 at 18:28
    
I would expect that we all miss the little things from time to time. Glad to read that it worked for you. :D –  Kory Wnuk Jun 26 '11 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.