Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just got my new Lenovo ThinkPad X220 with Intel HD graphics (I'm not sure what the chip is) and I've installed Natty. Everything works great out of the box, except there are short pauses/freezes in the UI that randomly occur, they last less than 2 seconds, actions are still taking place in the background (like typing) when the UI un-freezes I can see the characters I've typed, the app I've clicked, loaded .

I can confirm that this is only happening with the new Natty 3D interface, I've tried 2D and the classic interface and there were no issues.

Googling this topic seems challenging as I can't relate the problem in keywords. And I keep getting results relating to full GUI freeze which I don't have.

This is troubling since I have Natty 3D running on older machines without any issues .

I wonder if anybody else have experienced this or came across this issue before.

Thanks.

share|improve this question
    
Ahmad, have you installed all the updates for your machine? and if not can you please do that and report back if you are still encountering the problem. –  scouser73 Jun 22 '11 at 15:50
    
Good thing you chose Lenovo, they certify their hardware. Unlike myself when the UI freezes it freezes until I SSH from a different machine to restart Compiz. Ubuntu is extremely buggy, all you can really do is wait for updates. –  Dillon Gilmore Jun 22 '11 at 17:51
    
yep, everything is up to date, it seems to get worse after coming back from suspend mode. –  Ahmad Nassri Jun 23 '11 at 0:23
    
I have noticed the following message in dmsg every time this happens: [ 1047.425428] [drm:i915_hangcheck_ring_idle] ERROR Hangcheck timer elapsed... blt ring idle [waiting on 377417, at 377417], missed IRQ? –  Ahmad Nassri Jun 24 '11 at 5:11

2 Answers 2

up vote 3 down vote accepted

I've found the solution (and the source of the problem) it seems something to do with the intel driver, and apparently it has been fixed in newer kernels not yet released to 11.04.

the quick fix is to run the following:

echo 1 | sudo tee /sys/module/i915/parameters/semaphores

this temporarily fixed the problem for me, but the setting is reset after reboot. to set it permanently try the puting this option in /etc/default/grub

replace following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

by

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.semaphores=1"

then update grub:

sudo update-grub
share|improve this answer
    
more details on the bug here –  Ahmad Nassri Jun 24 '11 at 5:29

I had some sort of problem what I did to make it faster. I put mine swap to a lower priority this made my machine faster. It still it isn't as fast 10.10.

Check the value in terminal

"cat /proc/sys/vm/swappiness": if this is 60 it's a bit high

To change this for one reboot

"sudo sysctl vm.swappiness=10"

Permantent

"gksudo gedit /etc/sysctl.conf" enter in text file at the bottom or if it's in the text file change it. vm.swappiness=10 save and reboot

Hope this works you can have a look at: https://help.ubuntu.com/community/SwapFaq

share|improve this answer
    
I figured the source of the problem (check the answer) but I'm going to try that to see if I can speed up my system even more ... all my Ubuntu machines have swappiness set to 60 is that the default value? –  Ahmad Nassri Jun 24 '11 at 18:21
    
@Ahmad Nassri 60 is default this is good for a server not best for some desktops if you have a fast hard disk you can take a higher value for better performance. –  Rens Jun 24 '11 at 20:30
    
good to know thanks! –  Ahmad Nassri Jun 26 '11 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.