Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the latest VirtualBox 4.0.8 (from the VirtualBox website), including the extension pack, running on Ubuntu Lucid 10.04. My user is a member of vboxusers.

The guest OS is Windows XP (32-bit).

Everything works -- except the USB. In the USB settings. I have set the default filter (to allow all USB devices). While the guest is running, I go to Devices > USB Devices and select the device (it's a simple USB stick formatted as FAT32).

Although the device is automatically unmounted from Ubuntu, Windows XP fails to see it (normally XP would have a little dialogue about installing a new device and then show the icon to safely remove a drive. It does not do this).

Any ideas how to solve this problem, so my guest Windows XP can see the USB stick?

share|improve this question
1  
This is unusual. Try rebooting the guest OS. –  Takkat Jun 22 '11 at 13:30
1  
You can check the windows device manager to rule out a windows driver problem. If the device is shown there then it's likely a windows problem. –  Javier Rivera Jun 23 '11 at 7:11
    
@Takkat: This has been repeatedly tried over several days, so both guest and host OS's have been booted several times. –  Paddy Landau Jun 23 '11 at 9:32
1  
@Javier Rivera: Thank you for your suggestion. A bit of Googling told me to look in Control Panel > System > Hardware. I found the USB with a yellow question mark. Right-click > install driver did the job. Thank you. I hope this helps someone with the same problem. –  Paddy Landau Jun 23 '11 at 9:59
    
Device manager didn't show anything for me, had to enable "plug and play" via services.msc in order to see USB error state; then did as @PaddyLandau above. –  pbhj May 25 '13 at 21:13
add comment

1 Answer 1

up vote 2 down vote accepted

A bit of Googling told me to look in Control Panel > System > Hardware. I found the USB with a yellow question mark. Right-click > install driver did the job. Thank you. I hope this helps someone with the same problem.

OP solved issue Comment to answer

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.