Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Lubuntu 12.04 on my Sony Vaio VGN-T150 after installing Win XP again; I had Lubuntu 12.04 on the laptop but wasn't getting any CPU fan operation. Tried adding vaiofand but still seemed like the fan was not working, CPU temps in the 60+ range.

Long story short, decided to install Win XP to see if fan worked under Windows before taking laptop apart to check hardware (also wanted to be able to dual-boot, so I figured this would be the easy way to do it and kill 2 birds w/1 stone). Win XP made no difference, so pulled laptop apart and found fan was binding due to crud; disassembled, cleaned, reinstalled - working now. That's when I reinstalled Lubuntu alongside Win XP.

Ever since, wireless is not working in Lubuntu; wireless adapter is Intel PRO/set 2200 and includes BT. BT appears to be operational. etho 0 (wired) LAN port works. In Win XP, in order to use wireless, BT must be off (can't use both a same time). I've turned BT off using BT manager, no change. Wireless switch is on.

I've read many forum posts for similar issues with this wireless adapter, so far no luck in resolving. From what I've gathered, it is not being recognized by Lubuntu.

Heres some data:

sudo lshw -C network

  *-network:0             
       description: Ethernet interface
       product: 82801DB PRO/100 VE (MOB) Ethernet Controller
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:02:08.0
       logical name: eth0
       version: 83
       serial: 00:01:4a:04:82:cb
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip=192.168.0.111 latency=66 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100Mbit/s
       resources: irq:9 memory:e0205000-e0205fff ioport:3000(size=64)

  *-network:1 UNCLAIMED
       description: Network controller
       physical id: b
       bus info: pci@0000:02:0b.0
       version: 05
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=64 maxlatency=24 mingnt=3
       resources: memory:e0206000-e0206fff

QUESTION: Is network:1 UNCLAIMED the wireless adapter???

Moving on:

rfkill list
0: hci0: Bluetooth
Soft blocked: no
    Hard blocked: no

I don't see anything listed for the wireless switch - ???? I know it works because if I switch it off, the LED on the front panel turns off, so hardware-wise I'm sure it's working.

Next I tried:

lspci -nn | grep -i network
02:0b.0 Network controller [0280]: Device [8080:0000] (rev 05)

Honestly, not sure what this means exactly, but I think it references the UNCLAIMED network listed previously. So I tried this next:

sudo modprobe ipw2200
lsmod | grep ipw2200
ipw2200               146210  0 
libipw                 46732  1 ipw2200
cfg80211              178877  2 ipw2200,libipw
lib80211               14040  2 ipw2200,libipw

dmesg | grep 2200
[ 2165.049453] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 2165.049464] ipw2200: Copyright(c) 2003-2006 Intel Corporation

I take this to mean that the driver is properly installed, hardware not recognized or "present" (since comparing this output to those I saw in other posts, there seems to be a few lines of data missing) - ???

Lastly I tried this:

dmesg | grep eth
[    0.063806] i2c-core: driver [aat2870] using legacy suspend method
[    0.063810] i2c-core: driver [aat2870] using legacy resume method
[    1.631372] e100 0000:02:08.0: eth0: addr 0xe0205000, irq 9, MAC addr 00:01:4a:04:82:cb
[   24.708310] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   27.202263] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   27.203933] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  221.820180] e100 0000:02:08.0: eth0: NIC Link is Up 100 Mbps Full Duplex
[  221.820855] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  232.208048] eth0: no IPv6 routers present

Which I assume is just telling me that my wired LAN is working, but not really sure what else this might tell me.

At this point I'm pretty much lost. I'm relatively new to linux, trying to ditch Windows for good!

Not sure why it seemed to work fine on my first install of Lubuntu (32-bit, BTW) but now after the Win XP install and dual-boot reinstall of Lubuntu, no dice. Any help would be greatly appreciated. I'd really hate to have to reinstall Lubuntu again. Could I boot to a live Lubuntu disk and see what happens with that, then try to figure out what is different that allows the live distro to work and not the installed one? Advice on how best to do that (where do I look)? Thanks in advance!

share|improve this question
    
Please edit your question to add the result of: dmesg | grep 02:0b Thanks. –  chili555 Jul 20 at 13:36
    
As requested, results of dmesg | grep 02:0b: [ 0.084312] pci 0000:02:0b.0: [8080:0000] type 0 class 0x000280 [ 0.084342] pci 0000:02:0b.0: reg 10: [mem 0xe0206000-0xe0206fff] Of note, and I guess I'm impatient, I decided to just reinstall Lubuntu 12.04 only, overwriting Win XP, just to see what would happen. I have same exact issue, so I'm confident that it's unrelated to the dual-boot with Win XP (HDD is only 40GB, so likely better to just have Lubuntu alone anyway). I did go back and run all the same commands I did before, just to verify I'd get same results (I did). –  MX372 Jul 20 at 14:55

2 Answers 2

I suspect your card is defective. First, the vendor and product ID, in your case, appear as:

02:0b.0 Network controller [0280]: Device [8080:0000] (rev 05)

8080:0000 does not correspond to any wireless device that Google or I know of. Here is the correct information: http://ubuntuforums.org/showthread.php?t=2198032

Network controller [0280]: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection [8086:4220] (rev 05)

As you can see, the ID is very different: 8086:4220.

Next, we checked for messages about the PCI bus 02:0b:0 suspecting an ACPI error or similar. The dmesg log said nothing alarming.

As a last resort, I suggest you read the repair manual, available on line, following all recommended precautions, open the laptop and check to see that the card is properly seated in the slot and that both antenna wires are firmly attached. If so, then I think the card is electrically defective.

share|improve this answer

Solved. Took laptop apart and checked everything - nothing looked out of place, disconnected, loose etc. Removed wireless board from slot anyway and reinserted (antenna was connected still) and double checked all other connectors. Put it back together and booted - wireless operational now. I have to assume that it was a poor connection at the wireless card, likely due to not being seated all the way from my previous disassembly to clean the fan.

Thanks for the help, I should have just done that in the first place. Hindsight is 20/20 they say. At least I learned a few Linux commands, even if I don't entirely understand them at this point. Means more to study and learn.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.