Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 11.04, and I am surprised to see icons cluttering up my whole desktop. All the folders and files under Home are represented. But if I delete the icons, the folder or file itself is deleted - the icon is not just a link. How can I clean up the desktop? None of the screenshots advertising Unity look like this.

share|improve this question
1  
Was this an upgrade or a fresh install? –  Takkat Jun 22 '11 at 7:32
    
It was a fresh install, from a DVD out of Ubuntu User magazine. –  Fanie van der Walt Jun 22 '11 at 8:35
    
The error may come from a custom DVD setup then. Try installing using the original CD or DVD image from Ubuntu. –  Takkat Jun 22 '11 at 8:49

2 Answers 2

Check the following configuration key:

gconftool-2 --get /apps/nautilus/preferences/desktop_is_home_dir

If the output is true, then set it to false:

gconftool-2 --set /apps/nautilus/preferences/desktop_is_home_dir --type bool false

then restart nautilus:

killall nautilus
share|improve this answer
    
When I set desktop_is_home_dir to false and restart nautilus, the icons disappear for a couple of seconds, but then they re-appear! –  Fanie van der Walt Jun 22 '11 at 8:33
    
The flag come back to true? In your home exists the directory Desktop, or the equivalent as it would be in your language? –  enzotib Jun 22 '11 at 8:37
    
No, the flag remains false. Yes, there is a Desktop folder; I have deleted its contents - the icons o n the desktop disappeared for a second, then came back. –  Fanie van der Walt Jun 22 '11 at 8:41
1  
I got an e-mail from Bilal Akhtar. My reply: I found this line in user-dirs.dirs (without the leading "#"): #XDG_DESKTOP_DIR="$HOME/" On adding the "#" to the start of the line, all icons from $HOME disappeared from the screen! Thank you very much. Problem solved. Fanie van der Walt. Bilal's solution: On 06/26/2011 11:22 AM, Bilal Akhtar wrote: > Could you check if XDG_DESKTOP_DIR in ~/.config/user-dirs.dirs is set to > "$HOME/Desktop" ? Seems like a configuration issue from your side > –  Fanie van der Walt Jun 26 '11 at 18:41
1  
@Fanie, could you add this as an answer? –  enzotib Jun 26 '11 at 18:44

As mentioned in another comment you need to edit the ~/.config/user-dirs.dirs file. What I saw was something like this:

XDG_DESKTOP_DIR="$HOME/"
XDG_DOWNLOAD_DIR="$HOME/"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/"
XDG_DOCUMENTS_DIR="$HOME/"
XDG_MUSIC_DIR="$HOME/"
XDG_PICTURES_DIR="$HOME/"
XDG_VIDEOS_DIR="$HOME/"

And I changed it to something like this:

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/Share"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

Then restart nautilus:

killall nautilus

or

nautilus -q

Then, open nautilus via Unity menu (press the Super key) or using the run command (Alt+F2)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.