Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just started using ubuntu as my main daily driver and have almost worked our the kinks.

There's one that is persistent though - I cannot boot using normal methods. I get booted into a black screen, which cannot do anything from - no Ctrl+alt+f1, no console - I do get the cursor however is a black X that does nothing but move when I move the mouse.

I have to use Advanced Ubuntu options whilst in GRUB and load up the recovery console, from here all I need to do is resume boot and it works fine.

Is there anyway I could fix this error without having to reinstall - I'm using an i7 4770k, 16gb of crucial ram, Nvidia GTX 770 and a Gigabyte GA-Z87-HD3. Not sure if that helps but it's better to have the info than not.

Edit: I'm using Nivdia Driver 331.67, I tried upgrading to the latest (340?) and had the same issue plus others so I went back to the driver I had installed before.

Thanks for the help.

share|improve this question
    
I think you may have a combination of two things together causing the problem, the Gigabyte GA-Z87-HD3 motherboard and the Nvidia GTX 770 graphics card. If you have a smaller graphics card handy and can temporarily swap it with the Nvidia GTX 770 graphics card and it works, then that would be a big help as it would point to a possible changing the Nvidia graphics card driver solution. Or if you don't have another graphics card this answer might work. –  karel Jul 19 at 4:25
    
If you can connect to internet in Ctrl+Alt+F2 mode, try with installing sudo apt-get install xserver-xorg-video-all –  Dumindu Mahawela Jul 19 at 4:41
    
@Karel That didn't work unfortunately - it doesn't bring the cursor up anymore just brings up a black screen with a pink line the height of my montior on the left side of the screen that holds my Unity Launcher. I could access ctrl alt f1 this time however and when I ran sudo service lightdm start or gdm start it came with up with black screen and cursor again. –  Jackybigz Jul 19 at 6:12
    
@user296776 I can load into ubuntu fine using the recovery console and have checked that xserver is installed. 0 to upgrade, 0 to newly install, 0 to remove and 27 not to upgrade. –  Jackybigz Jul 19 at 6:14
    
purge and reinstall it and see. –  Dumindu Mahawela Jul 19 at 6:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.