Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The xfce "indicator plugin" keeps crashing with almost all apps. However I need it. I just want it to keep trying to restart itself automatically (preferably every 10 seconds) instead of displaying this annoying message Plugin "Indicator Plugin" unexpectedly left the panel, do you want to restart it? Does anyone have an idea about how to do this?

share|improve this question

2 Answers 2

You could always remove the indicator and use the native XFCE notification area... I've found the indicator plugin under XFCE to be a pain to work with.

share|improve this answer
    
okay how do I get this notification area? –  Mina Michael Jul 19 at 7:38
    
It actually should be running already. If you have a laptop you will need to tell the power manager to always show the icon first. Settings Manager>Power Manager>General (page on left)>System tray icon> set it to "Always show icon" or When battery is present". Once that is done, right click on your XFCE panel>Panel>Panel Preferences>Items (tab)> remove Indicator Plugin. Make sure the "Notification Area" is listed, if not just click "Add new item to this panel" and search for it in the list. That will at least stop the errors about the indicator plugin and retain power and network icons. –  Robsteady Jul 19 at 12:52
1  
oh I found it. I had it working but it doesn't show my google hangouts plugin for example while the indicator plugin does! –  Mina Michael Jul 20 at 2:01
    
I'm having this problem as well, but with Skype and WPA GUI. Strangely on another machine with the exact same distro both these icons appear as they should in the "Notifications" panel. Not a big problem, just annoying as the "Indicators" panel doesn't honour my dark theme. –  Ola Tuvesson Aug 28 at 21:04
    
I eventually found a solution to the Notifications panel issue: a missing 32-bit package (sni-qt:i386) is required for the XFCE "Notifications" panel to work properly with QT apps in 64-bit XFCE. This package was not automatically installed on my machine and installing it fixed my problem: $ sudo apt-get install sni-qt:i386 Bye-bye "Indicators" panel, you won't be missed :) –  Ola Tuvesson Aug 28 at 21:24

I had a similar problem and found a bug report with a workaround that seems to do the trick. The workaround is as follows. I modified it a little so that you don't need to actually right click the active indicator panel, which could be tricky if it keeps crashing.

  1. Right click the panel and select Panel -> Panel Preferences
  2. Select the Items tab and add Indicator Panel if it's not already there
  3. Select Indicator Panel and click the edit button (spanner over a page)
  4. Click the Hidden checkbox next to Application Menus (Global Menu)
  5. Restart the panel: xfce4-panel -r

The screenshot below shows how what these menus should look like.

Screenshot of preferences to hide panel

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.