Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I recently installed Bumblebee on my computer, running 12.04 LTS. I used the optirun command to launch Steam, and it worked just fine. I try to launch Team Fortress 2 within Steam, it'll play one note of the intro video, and then crash. The terminal error reads:

The program 'hl2_linux' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 139 error_code 3 request_code 15 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Missing shutdown function for DevShotGenerator_Init() : DevShotGenerator_Shutdown()
Missing shutdown function for MapReslistGenerator_Init() : MapReslistGenerator_Shutdown()
Missing shutdown function for COM_InitFilesystem( m_StartupInfo.m_pInitialMod ) : COM_ShutdownFileSystem()
Missing shutdown function for Steam3Client().Activate() : Steam3Client().Shutdown()
/home/kelerak/.local/share/Steam/SteamApps/common/Team Fortress 2/hl2.sh: line 67:  3248 Segmentation fault      (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 3248

And then it goes to repeat this phrase:

(steam:2816): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

Does anybody know what's going on?

share|improve this question

1 Answer 1

Instead of running all of Steam with optirun I would suggest starting Steam normally and editing the program settings to use the launch command of "optirun %command%" (without the quotes). This will limit the memory of your graphics card to being used only by the game itself. I'm not sure if that will help with the other issues you are having but it may help.

share|improve this answer
    
Using optirun %command% didn't work. Now the game won't launch at all. –  user305974 Jul 18 at 19:28
    
That's strange, if that is the case there may be a problem with your Bumblebee installation. Have you tried running optirun glxgears in a terminal to verify it is workin correctly? –  Robsteady Jul 18 at 19:32
    
optirun glxgears runs just fine. I don't know what it is, maybe a problem with the game's code or something. –  user305974 Jul 18 at 19:35
    
Another thing to do for the sake of troubleshooting is to turn off the steam overlay and see if that helps. I know I had problems with the overlay with Bumblebee at one time. What kind of Nvidia card do you have? Also are you using Bumblebee or Bumblebee-nvidia. The open source drivers still aren't quite as good as the nvidia ones so it might not hurt to try switching to that if you're not using it. –  Robsteady Jul 18 at 23:36
    
I have an NVIDIA GeForce GT 640m graphics card. I installed the version of Bumblebee I have following the instructions I found here: wiki.ubuntu.com/Bumblebee –  user305974 Jul 18 at 23:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.