Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I fix this issue:

libgles2-mesa : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.7)

I have already installed libglapi-mesa.

 $ sudo apt-get install libgles2-mesa
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libgles2-mesa : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.7)
E: Unable to correct problems, you have held broken packages.


 $ sudo apt-get install libglapi-mesa
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libglapi-mesa is already the newest version.
The following packages were automatically installed and are no longer required:
  libts-0.0-0 libmodplug1 libtwolame0 libva-x11-1 libzvbi-common libx264-120 libbluray1 libzvbi0
  libxcb-xv0 libtar0 libdca0 libwebkitgtk-1.0-common libterm-readkey-perl libiso9660-8 libcddb2
  libass4 libdvbpsi7 libdirectfb-1.2-9 libjavascriptcoregtk-1.0-0 libsdl-image1.2 libenca0
  libresid-builder0c2a libupnp3 libaacs0 libmatroska5 libxcb-keysyms1 liba52-0.7.4 libdvdnav4
  libdvdread4 libxcb-composite0 libkate1 libjpeg62 libsidplay2 gir1.2-rsvg-2.0 tsconf
  libwebkitgtk-1.0-0 libmad0 python-support libdirac-encoder0 libsvn-perl libvcdinfo0 libebml3
  libmpcdec6 libcrystalhd3 libmpeg2-4 libxcb-randr0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 695 not upgraded.

This is the output of sudo apt-cache policy libglapi-mesa:

$ sudo apt-cache policy libglapi-mesa
libglapi-mesa:
  Installed: 9.0-0ubuntu1
  Candidate: 9.0-0ubuntu1
  Version table:
 *** 9.0-0ubuntu1 0
        100 /var/lib/dpkg/status
     8.0.4-0ubuntu0.7 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     8.0.4-0ubuntu0.6 0
        500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     8.0.2-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

And I have read How do I resolve unmet dependencies?, but that does not solve my problem.

share|improve this question

1 Answer 1

I don't know why you have a newer version of libglapi-mesa, but that's not right. You need to downgrade the package (and maybe others) to fix the issue:

sudo apt-get install -f libglapi-mesa=8.0.4-0ubuntu0.7

It will probably tell you that you need to downgrade other packages, answer "Y".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.