Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

When I try:

sudo apt-get install ffmpeg

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ffmpeg' has no installation candidate

And I don't know how to install ppa packages.

share|improve this question

marked as duplicate by Rinzwind, karel, Eric Carvalho, Mahesh, Seth Jul 19 '14 at 20:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
this means there is nothing like ffmpeg in ubuntu repository you have to download it and install it manually from terminal – Creator Jul 18 '14 at 14:50
    
see askubuntu.com/questions/432542/… (aconv is the new ffmpeg ;) ) – Rinzwind Jul 18 '14 at 14:50
    
@Rinzwind - I answered what he asked :D – Creator Jul 19 '14 at 8:44
up vote 2 down vote accepted

Try these running these commands on your system to install ffmpeg

cd ~/ffmpeg_sources
wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
tar xjvf ffmpeg-snapshot.tar.bz2
cd ffmpeg
PATH="$PATH:$HOME/bin" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="$HOME/ffmpeg_build" \
  --extra-cflags="-I$HOME/ffmpeg_build/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
  --bindir="$HOME/bin" \
  --extra-libs="-ldl" \
  --enable-gpl \
  --enable-libass \
  --enable-libfdk-aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libtheora \
  --enable-libvorbis \
  --enable-libvpx \
  --enable-libx264 \
  --enable-nonfree \
  --enable-x11grab
PATH="$PATH:$HOME/bin" make
make install
make distclean
hash -r

for more details see this installation guide

share|improve this answer
    
Your answer is correct. I am now using ffmpeg. – user306837 Jul 18 '14 at 17:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.