Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 "LTS" on a Lenovo W530 (Nvidia Optimus architecture) and updated the kernel to 3.13.0-32-generic as the version of the kernel I was running was going out of support, 3.5.0-52-generic. I was getting the following warning;

"Your current Hardware Enablement Stack (HWE) is going out of support on 08/07/14. After this date security updates for critical parts (kernel and graphics stack) of you system will no longer be available."

I went through some pain to get a second monitor working with this machine in the past and after the update to the new kernel all that work went away. The screen resolution went to 800x600 and the secondary monitor no longer worked. My machine is a work laptop and I thought LTS was a safe bet but obviously not...

I did some investigation on the problem and tried the following;

Purged the nvidia drivers, reinstalled nvidia current and restart;

sudo apt-get purge 'nvidia*'
sudo apt-get install nvidia-current
sudo reboot

Tried to install the latest version of the nvidia drivers in the repo;

sudo apt-get purge 'nvidia*'
sudo apt-get install nvidia-331
sudo reboot

Configured nvidia xconfig, load the drivers and restart the UI;

sudo nvidia-xconfig
sudo modprobe nvidia
sudo service lightdm restart

This lead me to an error in dmesg thrown by trying to load the Nvidia driver with modprobe. Basically the driver doesn't load.

nvidia: module licence 'NVIDIA' taints kernel

nvidia: Unknown symbol acpi_os_wait_events_complete (err 0)

Which lead me to the nvidia forum which outlines a way to patch the system https://devtalk.nvidia.com/default/topic/644906/linux/331-20-on-3-13-rc1-kernel/

There's a mix bag of information around a fix with nothing really concrete there. There's a bug in the new kernel that breaks the Nvidia driver (from my understanding) and there's some steps to patch it yourself. Again this machine is for work and I don't want to be messing around so I decided to revert back to the previous working kernel;

sudo apt-get remove linux-image-3.13.0-32-generic
sudo reboot
uname -r

3.5.0-52-generic

sudo apt-get purge 'nvidia*'
sudo apt-get install nvidia-current
sudo nvidia-xconfig
sudo modprobe nvidia
sudo service lightdm restart

Everything is back the way I had it but this doesn't solve the fact that after August I'll no longer recieve security updates. I thought this was a LTS...

Is there any information around an official fix for this before August. Or if anyone knows how I can update to 3.13.0 without breaking Nvidia graphics driver?

share|improve this question
    
Try running hwe-support-status and see what it recommends. –  Paul Jul 18 at 17:23
    
Running that command gives me the same warning as logging into tty1: Your current Hardware Enablement Stack (HWE) is going out of support on 07/08/14. After this date security updates for critical parts (kernel and graphics stack) of your system will no longer be available. For more information, please see: wiki.ubuntu.com/1204_HWE_EOL To upgrade to a supported (or longer supported) configuration: * Upgrade from Ubuntu 12.04 LTS to Ubuntu 14.04 LTS by running: sudo do-release-upgrade OR * Install a newer HWE version by running: sudo apt-get install –  ismisepaul Jul 21 at 9:00
    
I've ran a live CD of 14.04 and the Nouveau driver works out of the box with the Optimus turned on in the BIOS (Lenovo W530). So I might just update to 14.04 before the HWE runs out of support –  ismisepaul Jul 21 at 9:04
    
What you are getting may be related to bugs #1341320 and #1341324. –  Paul Jul 25 at 18:30
    
I've had the same problem as you. Your final solution sudo apt-get remove linux-image-3.13.0-32-generic sudo reboot gave me a breath. It solved my no-X-system problem Thanks! –  antonioraju Jul 29 at 18:51

1 Answer 1

This is a bug and I expect them to fix this so it will work out of the box soon, but if you want to use the new kernel you can do the update and do the following afterwards after booting to get it working again.

Open a terminal (hold in CTRL and ALT while pressing T) Add xorg-edgers PPA and update

sudo add-apt-repository ppa:xorg-edgers/ppa

You'll have to supply your password when prompted. You'll get all sorts of info about this repo but to continue just press ENTER

Now in the same terminal:

sudo add-get update
sudo apt-get install nvidia-current

If you have an old machine you just replace nvidia-current with nvidia-304. You need to press Y + ENTER for it to be installed.

When it's finifshed you restart your system. To confirm that you are indeed using Nvidia drivers you may open System settings in the menu on top right and choose Additional Drivers from the Hardware section. It takes some time for it to start up but when it's there it will tell you if you are using Nvidia driver. It might be that you could in fact activate your driver from this view after sudo add-get update but I didn't do that so I'm not 100% sure. Before the HWE update I had several choices here but now I only have the one I have installed.

Hope this fixes things until April 2017 :-p

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.