Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After spending a while figuring out Calibre's news fetching feature, and spending another while slowly editing the recipes as it maxed out the cpu, I was disappointed to find that resulting the ebooks were all 0.0Mb. I disabled my proxy but still no good.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Try using ebook-convert ~/.config/calibre/custom_recipes/(your recipe) test.epub --test -v -v in a terminal and see if any error or warning messages are produced.

share|improve this answer
    
I don;t have a custom_recipes folder even though I have edited several of the stock recipes. Trying a stock recipe I get the same problem . I see that the program is still using the proxy I normally use, 127.0.0.1:8123 even though I have disabled it with gnome. –  daithib8 Jun 21 '11 at 17:32
    
I logged out after disabling the proxy and it works now. Curious how it wouldn't obey the gnome proxy applet. –  daithib8 Jun 21 '11 at 18:14
    
Most likely it only reads the proxy once, since it can't hook into gconf (or whatever it is this week) properly. BTW, the builtin recipes can be run the same way but they live somewhere else; I'd have to check where though (my primary calibre environment is on OSX). –  geekosaur Jun 21 '11 at 18:20
    
Yes, but I restarted Calibre after updating the proxy settings. I searched for calibre recipes and there aren't any in my home folder. –  daithib8 Jun 21 '11 at 18:48
    
The system ones won't be in your home folder. Again, I would have to dig to find out where they are on Ubuntu, but it will be under /usr somewhere for an Ubuntu package and under /opt/calibre for the standard install. As to the proxy, the other possibility is that it uses the environment, which indeed will require logout/login if your window/desktop manager isn't smart enough to update its own environment when the proxy settings are changed. –  geekosaur Jun 21 '11 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.