Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.04 LTS recently. I installed Nvidia drivers running the following in the terminal :

$ sudo apt-get purge nvidia-* 
$ sudo apt-get update 
$ sudo apt-get install nvidia-current-updates 

I also tried installing via the RUN file : link.

After executing the RUN file and rebooting, my screen resolution is stuck at 640 X 480. I have a FHD screen.

I have run sudo apt-get purge nvidia-* again, and now want to ask how can I ask fix this problem. Right now I have nothing relevant to Nvidia on my system.

Running sudo dpkg --get-selections | grep nvidia gives me an empty result.

My screen resolution is still 640 X 480.

(there are so many answers out there on this topic and commands in various order, that I had to ask it again, sorry if its exactly a duplicate)

Edit

I tried uninstalling using the run file, and it asked me if I want to bring back the backedup x settings. I clicked yes. After uninstall & reboot, the desktop just had a wallpaper.

Then I ran :

sudo apt-get install nvidia-current-updates 

I rebooted again. Right now desktop looks normal.

If I run

sudo dpkg --get-selections | grep nvidia

I get

nvidia-304-updates              install
nvidia-current-updates          install
nvidia-settings                 install

My system settings still shows Graphics : unknown.

How do I tell if my display drivers are configured correctly ?

I can also run :

 $ nvidia-settings

and a window titled Nvidia X Server Settings pops up. Does this mean everything is ok , despite settings telling me unknown graphics ?

Edit 2

I tried installing mesa-utils, now instead of showing unknown graphics, it shows it as blank :P .. is that better ?

enter image description here

Edit 3

I think my nvidia driver is still no configured properly. Referring this answer

When I run :

glxinfo | grep vendor

I get

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

Expected output :

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

What to do ?

Edit 4

I also tried

$ lshw -c video
WARNING: you should run this program as super-user.
*-display UNCLAIMED     
   description: VGA compatible controller
   product: GK208M [GeForce GT 730M]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list
   configuration: latency=0
   resources: memory:f0000000-f0ffffff memory:c0000000-cfffffff 
   memory:d0000000-   d1ffffff ioport:3000(size=128)
   *-display
   description: VGA compatible controller
   product: 4th Gen Core Processor Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:49 memory:f1000000-f13fffff memory:e0000000
   -efffffff ioport:4000(size=64)
   WARNING: output may be incomplete or inaccurate, you should run 
   this program as super-user.

Does this indicate everything is in order ?

Edit 5

Here's my additional driver window :

enter image description here

Should I go ahead & enable 304 ?

Edit 6

After running

 sudo apt-get install nvidia-current

as per one of the suggestions, the additional driver windows changed to :

enter image description here

Also :

$ sudo dpkg --get-selections | grep nvidia
nvidia-304                  install
nvidia-304-updates          install
nvidia-current              install
nvidia-current-updates      install
nvidia-settings             install

Graphics settings is still blank.

Running $nvidia-settings shows me :

enter image description here

What is left to do ??

Edit 7

With no one replying ... I am installing the last entry in the list, and deactivating 304. Now I will try sudo nvidia-xconfig & a reboot. fingers crossed ..

enter image description here

share|improve this question
    
To see the current driver run lshw -c video –  user107425 Jul 16 at 17:11
    
@user107425 please see edit. –  Jake Jul 16 at 17:12
    
@user107425 I edited with the command you suggested. –  Jake Jul 16 at 17:14
    
Your running the Intel video driver. configuration: driver=i915 –  user107425 Jul 16 at 17:31
    
@user107425 Please look at the edit I just made. –  Jake Jul 16 at 17:31

2 Answers 2

I am not sure but think so Ubuntu not providing Nvidia latest driver version directly. You need to get help from Nvidia.

I think you need latest driver version, remove 331 that already installed, you can get Nvidia various driver version. Latest released on July 10, 2014.

Click here.

share|improve this answer

You will need bumblebee to enable the nvidia gpu.

For 12.04

sudo apt-get remove --purge nvidia-*

sudo rm /etc/X11/xorg.conf

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install ubuntu-desktop linux-headers-generic-lts-raring

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update && sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

reboot

check these settings against your installed driver and adjust as necessary

sudo nano /etc/bumblebee/bumblebee.conf

*If you update the driver you will have to edit this file and adjust the settings.

Driver=nvidia

KernelDriver=nvidia-331-updates

LibraryPath=/usr/lib/nvidia-331-updates:/usr/lib32/nvidia-331-updates

XorgModulePath=/usr/lib/nvidia-331-updates/xorg,/usr/lib/xorg/modules

Usage [command] [option] [program]

optirun -b primus glxspheres

Or

primusrun glxgears

primusrun firefox

primusrun wine gta-vc.exe

primusrun steam

primusrun nvidia-settings

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.