Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to fix an issue with Ubuntu 14.04: my screen would freeze when the computer was woken after being asleep. I followed the instructions here (Ubuntu 14.04 System freezes on wakeup from suspended state) which lead me to the solution posted here (Ubuntu 14.04 install NVIDIA driver) to install an updated NVIDIA driver. I followed the steps there. This solved my problem, but a new one cropped up: a thick (1 inch) black border appeared around all of my windows, including popups. So, I decided I would get rid of NVIDIA--the old problem was less of an issue than the new one. I ran "sudo nvidia-uninstall" from the terminal, and then rebooted.

Upon reboot, I attempted to sign in, but when I did nothing happened: neither the launcher nor the dash appeared. This seemed to describe the trouble I was having: Unity doesn't load, no Launcher, no Dash appears. So, I followed the most popular solution here, installing Compiz Settings Manager. I followed the instructions on that page to turn on Unity. And then I returned to the terminal and rebooted, as instructed.

At this point I still cannot sign in. When I return to the Compiz Settings Manager, the Unity Plugin is listed as turned on.

From here, I tried resetting Unity by installing the Unity Tweak Tool, and followed the steps here: Ubuntu Desktop does not load. Everything installs fine. When I try to run the unity tweak tool, however, I get a repeating error message of "dconf-WARNING **: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY". I then made sure that I had X11 installed, and followed the instructions here: How to install X11/xorg?. Still the problem persists.

Any help would be greatly appreciated. I have no idea what to do to fix this, and really need my computer to be working.

share|improve this question
    
did you check your screen resolution to see if that was why you were getting black bars? –  mchid Jul 16 at 16:20

2 Answers 2

If you are not going to use the nvidia driver you probably need to re-install the nuouveau driver. You can do this by pressing CTRL + ALT + F2 after you power up your computer. From there, you can sign into a text session using your username and password. After you sign in, type the following commands:

sudo apt-get update
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install libdrm-nouveau2 xserver-xorg-video-nouveau nouveau-firmware
sudo reboot

After you reboot, everything should be back to the way it used to be.

If that does not work, try resetting compiz and unity by using the following commands:

sudo apt-get install wget python dconf-tools
wget https://launchpad.net/~amith/+archive/ubuntutools/+build/3910667/+files/unity-reset_0.1-8_all.deb
sudo chmod +x unity-reset_0.1-8_all.deb
sudo dpkg -i unity-reset_0.1-8_all.deb
sudo apt-get -f install
unity-reset
dconf reset -f /org/compiz/
compiz --replace
sudo reboot
share|improve this answer
    
Thank you for your post! I just tried it and unfortunately I'm still stuck. Everything seemed to download fine. Then I rebooted. And when I signed in I still couldn't see anything. What other information can I give to help? –  user3680688 Jul 16 at 16:30
    
Just tried the new suggestion. Everything seems to install fine. But once I enter "unity-reset" I get the same thing spit out at me again and again: "dconf-WARNING **: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY". –  user3680688 Jul 16 at 17:13
    
Thanks for all of your help, mchid. But I just reinstalled Ubuntu 14. I've already wasted a morning troubleshooting the issue; no telling how much longer this could go on. –  user3680688 Jul 16 at 18:23

I have the same issue and trying to solve this last two days.

what working for me :

  1. First I removed all package related to nvidia

    sudo apt-get purge nvidia-* and type y for yes.

  2. Try to reboot, ubuntu will load the default open source video driver Nouveau for NVIDIA graphic card, and you will get a default resolution screen of something like 800x600.

  3. Login and try to get console by Ctrl + Alt + T. Note : It's possible that you got an "internal system error" popups by Apport, the repport indicate that xserver-xorg failed.

  4. when you got Terminal, type

    sudo apt-get install --reinstall xserver-xorg

    dconf reset -f /org/compiz/

    setsid unity

then unity launcher and compzition come back.

  1. try to reboot to see if the change is persistent.

  2. If yes, open the dash home by press "Super (tap)", and type "additional driver" click on the application icon, when launched, select an nvidia driver, in my case "NVIDIA binary driver version 340 (open source)" and click on apply change.

  3. reboot to see if the change is persistent.

it work for me in this order after trying different solution proposed in askubuntu.

good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.