Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new Asus n550jv laptop which has a Intel AC 7620 wireless card inside of it. I installed Arch Linux on it and noticed that I will be connected to my corporate wifi and every once and a while I will just lose all internet connectivity, but my wifi connection says it's fine. After enough times of connecting and restarting, sometimes it seems to work. I got it to randomly yesterday for almost 4 hours. I tried going to linux-wireless and downloading the newest iwlwifi driver I can use, version 22.24.8.0. Didn't seem to help. Also tired the solution in No more internet connection after update in 14.04 with Intel Dual Band Wireless AC 7260 and that didn't work as well. I have tried using different distros in some vain attempt to fix this: Arch Linux, Linux Mint 17, Ubuntu 14.04, Ubuntu 12.10, and a new other Ubuntu variants.

The module parameters right now

sudo grep -H '' /sys/module/iwlwifi/parameters/*

/sys/module/iwlwifi/parameters/11n_disable:0
/sys/module/iwlwifi/parameters/amsdu_size_8K:0
/sys/module/iwlwifi/parameters/antenna_coupling:0
/sys/module/iwlwifi/parameters/bt_coex_active:Y
/sys/module/iwlwifi/parameters/fw_restart:Y
/sys/module/iwlwifi/parameters/led_mode:0
/sys/module/iwlwifi/parameters/nvm_file:(null)
/sys/module/iwlwifi/parameters/power_level:0
/sys/module/iwlwifi/parameters/power_save:N
/sys/module/iwlwifi/parameters/swcrypto:0
/sys/module/iwlwifi/parameters/wd_disable:1

The module info

modinfo iwlwifi

filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003-2013 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-3160-7.ucode
firmware:       iwlwifi-7260-7.ucode
srcversion:     1E6912E109D5A43B310FB34
alias:          pci:v00008086d0000095Asv*sd00005490bc*sc*i*
... a ton of aliases here
alias:          pci:v00008086d00004232sv*sd00001201bc*sc*i*
depends:        cfg80211
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        69:B0:D0:A7:9B:85:D9:06:21:70:6E:8D:06:60:4D:73:0B:35:9F:C0
sig_hashalgo:   sha512
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
parm:           nvm_file:NVM file name (charp)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)

The dmesg for iwlwifi

dmesg | grep iwlwifi

[   23.538445] iwlwifi 0000:04:00.0: irq 54 for MSI/MSI-X
[   23.763701] iwlwifi 0000:04:00.0: loaded firmware version 22.24.8.0 op_mode iwlmvm
[   23.773794] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[   23.773849] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[   23.774078] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[   29.060120] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[   29.060349] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[   33.188933] iwlwifi 0000:04:00.0: No association and the time event is over already...
[ 1364.975013] iwlwifi 0000:04:00.0: RF_KILL bit toggled to disable radio.
[ 1366.269647] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
[ 1366.270713] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[ 1366.270957] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[ 1579.332242] iwlwifi 0000:04:00.0: RF_KILL bit toggled to disable radio.
[ 1582.073419] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
[ 1582.075299] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[ 1582.075551] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S

Has anyone else had this problem? I have been trying to fix this for almost 2 months.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Ok so it didn't perfectly fix everything. But adding

options iwlwifi 11n_disable=1 bt_coex_active=0

to a /etc/modprobe.d file (you can name it whatever) even though I thought I tried this once already.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.