Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My internet connection is extremely slow after installing 11.04, It took me over night to download and install firefox flash player pluggin. I have a laptop on the same network which is running windows7 and the speed from that is extremely fast. Update manager is showing 10.1kb/s. This is really surreal.

I have done some googling around and noticed others having the same problem recommend the command below to do the trick:

sudo -s
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
reboot

I am not using Atheros wire/wireless card. My machine is installed with Broadcom Gigabit Ethernet card. Do anyone know how to resolve this issue.

I have done some search around here, and found a few post which seems to experience the same issue - but none of the suggested solution seems to help.

When i run lspci, i get below output.

00:00.0 Host bridge: Intel Corporation E7230/3000/3010 Memory Controller Hub (rev 81) 00:01.0 PCI bridge: Intel Corporation E7230/3000/3010 PCI Express Root Port (rev 81) 00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01) 00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01) 00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01) 00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01) 00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01) 00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01) 00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1) 00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01) 00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01) 00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01) 01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 220] (rev a2) 01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1) 07:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit Ethernet PCI Express (rev 11)

Thanks

share|improve this question
2  
possible duplicate of askubuntu.com/questions/46836/… –  suli8 Jun 21 '11 at 13:30
    
Downloading Flash may be slow because you hit a slow mirror. Test your connection with speedtest.net to make sure it's really slow. –  mikewhatever Jun 21 '11 at 17:24
    
I have followed the instruction from the link above and no joy. installing application take extremely long time. Ubuntu software centre installations are extremely slow. –  Bitmap Jun 21 '11 at 22:01
    
Do you think rollback to 10 will be any good? –  Bitmap Jun 22 '11 at 8:00
    
@bitmap - you perhaps need more details about your card (lspci, lshw) etc - are you talking about a wireless card or a wired connection? If a wireless card, does this solution work for your?/ ubuntuforums.org/showthread.php?t=1604868&page=22 –  fossfreedom Jun 22 '11 at 20:10

1 Answer 1

up vote 0 down vote accepted

After days of struggling with my connection speed, I finally decide I go down to the port level to investigate. Both my phone and ADSL were going via the same micro-filter. I had a spare phone port and micro-filter available therefore I have seperated the phone and ADSL to have their own independent telephone port, each connected through a micro-filter.

I then phone my provider to made a little fuss - now I am back to the super rocket speed again.

Thanks all for your support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.