Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 14.04 on my laptop and things are great except that it gets quite hot sometimes. I'm using sensors (lm-sensors) to report temperature and fan speed. I run a Thinkpad T430s with Ivy Bridge core i5.

When I am at home, plugged into power, the CPU temps reach over 90*C. When I'm at work, docked into my laptop, the fan speeds run higher and temps hover around 80*C. Any one knows why this might be the case?

Kernel:

3.13.0-24-generic #47-Ubuntu SMP

sensors output, no dock:

thinkpad-isa-0000
Adapter: ISA adapter
fan1:        4063 RPM

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +90.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +84.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +90.0°C  (high = +87.0°C, crit = +105.0°C)

sensors output, docked:

acpitz-virtual-0
thinkpad-isa-0000 
Adapter: ISA adapter
fan1: 4680 RPM

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +81.0°C (high = +87.0°C, crit = +105.0°C)
Core 0: +74.0°C (high = +87.0°C, crit = +105.0°C)
Core 1: +81.0°C (high = +87.0°C, crit = +105.0°C)
share|improve this question

1 Answer 1

I don't own a thinkpad and cannot tell precisely why there is a difference in fan speed in the two cases. Regardless it seems the system is running too hot even with the higher fan speed.

However, I did get significant cooling of my laptop using tlp. Try installing it as described here. You will have to purge laptop-mode-tools package if it is installed on your system else tlp will refuse to start. Since it was originally written for thinkpad laptops, it should work even better for your case. Note the two optional thinkpad packages mentioned on the page which could further help for thinkpad.

If the above does not help for your case, then you can enable intel p-state available in recent kernels. Enable it as described here. I don't use thermald as mentioned on that page since I did not have overheating problem, and I will not suggest trying that given what it says on that page about the state of thermald. Check pstate is getting used correctly: cat /sys/devices/system/cpu/*/cpufreq/scaling_driver should show intel_pstate. Try setting the governor to powersave for both AC and Battery in tlp instead of cpufrequtils as mentioned on that page: sudo gedit /etc/default/tlp, search for CPU_SCALING_GOVERNOR and add:

CPU_SCALING_GOVERNOR_ON_AC=powersave
CPU_SCALING_GOVERNOR_ON_BAT=powersave

Then restart tlp: sudo service tlp restart Check if it has taken affect: cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor should show powersave

If even that doesn't work well for you, then you could try installing a newer kernel (as I have been using) which has better p-state implementation. This is really the VERY LAST RESORT if everything else fails to cool down the laptop. Get the debs from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15.5-utopic/. You will need amd64 packages (assuming you have 64-bit Ubuntu installation) for linux-image-*-generic, linux-headers, and linux-headers-*-generic.

Additionally you could try installing the thinkfan package for controlling the fan on thinkpads but I have no experience of using it so cannot provide any tips for the same. You can also check the howto's given here for thinkpads specifically those dealing with power management like this.

Edit: with tlp you may have to also explicitly disable ondemand/cpufrequtils for the "powersave" p-state governor to take affect as I mentioned above. See this.

share|improve this answer
    
Thanks for the detailed response! I forgot to mention that the temperatures reached are when the system is under heavy load (which is often the case for me), and that when it is idling, it does not run nearly so hot. I will try first the thinkfan package, and then contemplate the other choices if it does not do what I want... –  andrew Jul 16 at 6:22
    
My laptop never goes beyond 70C even on max possible load (multi-threaded compilations, or real high stress with 120threaded client-server app I work on) which is why I mentioned it looks to be running hotter. However, mine uses more recent Haswell processor which might explain the difference. –  sumwale Jul 16 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.