Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

locale command should be . LANG=en_US.UTF-8.

My setting are .

locale 
LANG=en_AU.UTF-8
LANGUAGE=en_AU:en
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C

local file config

   cat /etc/default/locale : 
   LANG="en_US.UTF-8"
   LANGUAGE="en_US:en"

   cat /etc/locale.conf
   LANG="en_US.UTF-8"

What I have already done.

sudo locale-gen en_US.UTF-8 : 
Generating locales...
en_US.UTF-8... up-to-date
Generation complete.

sudo dpkg-reconfigure locales
Generating locales...
  en_IN.UTF-8... done
  en_US.UTF-8... up-to-date
Generation complete.

Please Let me know if you need any thing.

I am not sure /etc/default/locale file is default or custom.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I just add to my home profile.

gedit ~/.profile its look like:

LANG="en_US.UTF-8"
LANGUAGE="en_US:en"

Log out + Log in. And all is as expected.

share|improve this answer

Somewhere (can't tell where) the LC_ALL environment variable is assigned the value C. You need to get rid of that assignment.

The page https://help.ubuntu.com/community/EnvironmentVariables mentions a few files that are typically used to set environment variables persistently.

HTH

share|improve this answer

According to this useful link:

Each of the LC_* and LANG variables can contain a locale name of the following form:

language[_territory[.codeset]][@modifier] 

where language is an ISO 639 language code (lower case), territory is an ISO 3166 country code (upper case), codeset denotes a character set, and modifier stands for other particular attributes (for example indicating a particular language dialect, or a nonstandard orthography).

In order to fix this problem that seems a bug try:

  sudo localedef -v -c -i en_US -f UTF-8 en_US.UTF-8

it should compiles file for locale and C library.

share|improve this answer
    
Considering that the en_US.UTF-8 locale is already generated, I don't see how generating it again would make a difference to the OP's problem. –  Gunnar Hjalmarsson Jul 16 at 0:45
    
Because I read this "But unlike the locales package, compiled locale definitions are not removed when running locale-gen, and locales are compiled again only if locale source files have changed." in locale-gen manual. I guess that -c option in localedef command should compiles file in any case. Unfortunately I couldn't test this on my Ubuntu because my locale is right. –  Letizia Jul 16 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.