Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell 17xps with an NVidia Optimus 555M graphics card.

History

It's all worked OK with Ubuntu 12.x and bumblebee, but I really want to use 14.04 and nvidia-prime.

I've basically been following these instructions: How to get an Optimus 650 working

Everything worked fine until reboot. After reboot, /dev/nvid* was empty. I found someone else talking about this on X.org here and added the script to my cron at reboot.

Symptoms

  1. It boots and ls /dev/nvid* gives results. It prompts me with Unity's login screen. But when I login, it just hangs. I can basically see the mouse and the login background and it just stays there. I Ctrl-Alt-F1 and look a the syslog and there's nothing interesting. No video errors at all.

  2. i. I installed fluxbox, which I have used before. When I login to that, it seems great. Fluxbox is limited, so GLXGears doesn't like it (anyone know if there's a way around that?), but everything seems to render. I can't tell for sure if I'm on the NVidia side of the card or the Intel, but from the heat of the laptop, it feels like the NVidia side.

    ii. In fluxbox, I can open Nvidia-settings. And I don't have an NVidia PRIME section. No clue why? If I try to install nvidia-prime, it tells me it's already installed. But it's not on the settings box.

  3. I have no xorg.conf file in /etc/X11... don't I need one? I'm sure I didn't delete it. I remember nvidia-xconfig (I think?) will create one, since fluxbox is loading without one, maybe I'm wrong? I know nvidia-xconfig has broken my system before.

I'm running NVIDIA 331.38 drivers.

lspci gives me this:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF116M [GeForce GT 555M/635M] (rev a1)
share|improve this question
    
I'm begging to think no one else has this card and that NVidia never tested the drivers. I reached out to NVidia and still don't haven't been granted privs to ask a question in their forums (...waiting...). I'll let you know if I hear more. –  kjhngisd Jul 20 '14 at 12:25
    
I found this link maybe it can be helpful –  Lety Jul 20 '14 at 16:02
    
Thanks Letizia, I'll take a look –  kjhngisd Jul 21 '14 at 22:27
    
I checked the link, Letizia -- no luck. It's interesting, but my .nvidia-settings-rc has no attributes, so loading it or not doesn't matter. Thanks, though –  kjhngisd Jul 22 '14 at 2:56
    
Oh, also found out that the .nvidia-settings-rc seems to get overwritten on each reboot, if i'm using the nvidia drivers. And the xorg.conf is deleted. So changing either isn't helpful. –  kjhngisd Jul 22 '14 at 22:50

1 Answer 1

For anyone out there who still is in this situation, I upgraded to Ubuntu 15.04 and it looks lots better. I still haven't set up full prime support, but I do have 1600x900 resolution again (couldn't get more than 1024x768 with 14.04 or 14.10.). --kevin

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.