Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been able to use Juju from my home machine, however, when I attempt to use it from my work machine (which sits behind a proxy) I get:

(Output from juju quickstart --debug)

retrieving the Juju API address 10:06:20 DEBUG utils@call:94 running the following: /usr/bin/juju api-endpoints -e local --format json 10:06:21 DEBUG utils@call:104 retcode: 0 | output: '["10.0.3.1:17070"]\n' | error: '' connecting to wss://10.0.3.1:17070 10:06:21 DEBUG juju@send:130 API message: --> {"Request": "Login", "Params": {"Password": "password", "AuthTag": "user-admin"}, "Type": "Admin", "RequestId": 0} 10:06:21 DEBUG juju@recv:139 API message: <-- {"RequestId":0,"Response":{}} requesting juju-gui deployment charm URL: cs:precise/juju-gui-92 10:06:21 DEBUG juju@send:130 API message: --> {"Request": "ServiceDeploy", "Params": {"CharmURL": "cs:precise/juju-gui-92", "NumUnits": 0, "ToMachineSpec": null, "ServiceName": "juju-gui", "Config": {}, "Constraints": {}}, "Type": "Client", "RequestId": 1} 10:06:41 DEBUG juju@recv:139 API message: <-- {"RequestId":1,"Error":"cannot upload charm to provider storage: 500 500 INKApi Error","Response":{}} juju-quickstart: error: bad API response: cannot upload charm to provider storage: 500 500 INKApi Error ERROR exit status 1

My .bashrc is set as:

export http_proxy="http://proxy.mycompany.com:8080" export https_proxy="http://proxy.mycompany.com:8080" export ftp_proxy="http://proxy.mycompany.com:8080" export HTTP_PROXY="http://proxy.mycompany.com:8080" export HTTPS_PROXY="http://proxy.mycompany.com:8080" export FTP_PROXY="http://proxy.mycompany.com:8080" export no_proxy="localhost,127.0.0.1" export NO_PROXY="localhost,127.0.0.1"

I have the proxy also set in /etc/default/lxc (for both, MIRROR and SECURITY_MIRROR) and verified LXC works.

When I run juju quickstart I create a new LXC local environment and I use defaults. This is installed on a bare Ubuntu 64-bit 14.04 install with the latest updates and juju-local and juju-quickstart packages. This also occurs if I try to deploy a local charm.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Figured out the issue.

After the environment is bootstrapped, changes to the environments.yaml file don't seem to take effect. The settings are pushed into the *.jenv file for that environment. Because I was using quickstart, the settings were pushed in prior to any changes made. The solution is to "juju destroy-environment --force", modify the environments.yaml file based on your needs, then perform a "juju bootstrap".

I stumbled on this when I unplugged my computer from the network, and removed ALL proxy settings everywhere and attempted to deploy a local charm. It still tried to use the proxy for 10.0.3.1. A "grep -r 'myproxy.com'" pointed to the *.jenv file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.