Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the text seems blurry I'd like to disable antialiasing in gedit.

I don't see anything related in the program's Preferences.

The problem appeared after upgrade from 12.04 to 14.04:

enter image description here

share|improve this question

2 Answers 2

This is a known and fixed bug in GNOME GTK 3.10 [used in Ubuntu Trusty 14.04].

It has been fixed in GTK+ 3.13.7 (unstable release). The fix will be available for the GTK+ 3.14 stable version in September, per Sébastien Wilmet (https://bugzilla.gnome.org/show_bug.cgi?id=715008#c27).

The solution is to patch the gedit desktop launcher (file gedit.desktop), setting an env parameter. The command line to use in a Terminal (Ctrl+Alt+T) is :

$ sudo sed -i "s|Exec=gedit %U|# Exec=gedit %U\nExec=env GTK_DEBUG=no-pixel-cache gedit %U|g" /usr/share/applications/gedit.desktop

This will comment out the original Exec=gedit %U and add the new Exec= cmd. line with the env setting.

share|improve this answer
    
It has been fixed in GTK+ 3.13.7 ... does this help? We don't even have 3.12 in Trusty. This is too much frustrating :( –  Anwar Shah Apr 13 at 18:40

Easy solution, do:

sudo apt-get install gnome-tweak-tool

then open tweak tool, go to Fonts and there you can select what kind of antialiasing you want to use.

PS. This will change antialiasing for the entire system, not just gedit.

share|improve this answer
    
Thanks, but the only blurry text is in gedit - while the background is white (Ubuntu / Ubuntu Mono font). This seems as gedit is treated differently. –  Esamo Jul 14 '14 at 13:18
    
Can you post a screenshot? –  mmm3743 Jul 14 '14 at 20:06
    
There it is: img842.imageshack.us/img842/7538/rjsw.png . Notice that line indexes are not blurry, but the colored text is. –  Esamo Jul 14 '14 at 20:51
    
Try setting antialigning to grayscale, and go to gedit Preference and set it to use system fonts, I don't think it will fix it, but it will make the fonts look better. Also, compleatlly unrelated, try Aptana Studio for web programming –  mmm3743 Jul 15 '14 at 14:28
    
System font is Ubuntu Mono 13, mine is 11. Bigger blurry text is not exactly what I need :) . Greyscale antialiasing looks different - better in gedit, but worse everywhere else, mainly web browser. –  Esamo Jul 15 '14 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.