Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If i run lspci | grep VGA I get below output which tells me below VGA cards are present on my computer.

01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 220] (rev a2) 08:02.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)

The ES1000 is an onboard card which came with my machine. Do anyone know how to disable this VGA on my machine.

The reason for this request is because if I run xrandr I get the output as shown below:

xrandr: Failed to get size of gamma for output default Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768 default connected 1024x768+0+0 0mm x 0mm 1024x768 50.0* 800x600 51.0 52.0 53.0
680x384 54.0 55.0
640x480 56.0
512x384 57.0
400x300 58.0
320x240 59.0

Which means I am not able to configure nVidia to accept smaller resolution.

Thank you.

share|improve this question
2  
I would check the BIOS for an option to disable the onboard GPU. –  htorque Jun 20 '11 at 20:05
add comment

2 Answers

up vote 7 down vote accepted

Disabling via BIOS option

Some computers have a BIOS option to disable the onboard graphics.

On boot, press your BIOS key and look for a graphics option you can disable.

Disabling via Blacklisting

If there is no BIOS option, you'll need to blacklist the onboard graphics by putting your kernel module that is loaded for your onboard graphics into the /etc/modprobe.d/blacklist.conf file.

ATI graphics usually load the fglrx kernel module.

N.B. if you run lsmod you should see what kernel modules are loaded. This will include any graphics kernel modules. You should see fglrx as being loaded for your integrated graphics.

Choose Accessories - Terminal and then type in the terminal

sudo nano /etc/modprobe.d/blacklist.conf

This will open a text editor with the contents of the current blacklisted kernel modules. Add at the end

blacklist fglrx

Save and reboot.

If you re-run lsmod then it should show that the kernel module fglrx is no longer being loaded. That means your integrated graphics is now disabled.

Setting your NVIDIA Card resolutions

As to your NVIDIA resolutions - have you activated any hardware drivers in the Administrator - Additional Hardware drivers window?

You'll need to run nvidia-settings to adjust your resolution when the driver is installed.

Type in the terminal

gksudo nvidia-settings
share|improve this answer
    
I have just rebooted my machine and checked the BIOS settings. No options available to graphics. nVidia driver is installed via Additional Drivers. How do you run nVidia-settings. –  Bitmap Jun 20 '11 at 20:30
    
Do you know how I can locate a kernel module for a specific device?! –  Bitmap Jun 20 '11 at 21:09
    
@bitmap - have updated - hope this helps –  fossfreedom Jun 20 '11 at 22:29
    
You are a star. –  Bitmap Jun 21 '11 at 8:28
add comment

Have a look at http://launchpad.net/~hybrid-graphics-linux for acpi_call.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.