Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 14.04 LTS in a dual-boot config with Windows 8.1 following the tutorial:

http://ubuntuforums.org/showthread.php?t=2227580

(I added an ext4 /home partition.)

Even after step seven,

Write bcdedit /set {bootmgr} "path\EFI\ubuntu\shimx64.efi" in the terminal

my PC will not show me a boot menu: Windows boots automatically.

I ran the command sudo efibootmgr -v and these is the output.

share|improve this question
    
Many UEFI systems have an option in the UEFI settings to change the boot order. If I am right, you need to set Ubuntu to boot first and make Windows Boot Manager boot second. –  FuzzyToothpaste Jul 13 at 16:15
    
@FuzzyToothpaste you should make that an answer. –  ubfan1 Jul 13 at 16:42
    
I didn't make it one because I didn't know if it would fix it for sure. Now that you have suggested it I will do that right now. –  FuzzyToothpaste Jul 13 at 17:40
    
user305139 Did you install Ubuntu in UEFI mode i.e. Not enabling Legacy Mode or BIOS Mode)? If you don't know what I am talking about, you're probably fine. –  FuzzyToothpaste Jul 13 at 18:15
    
Please read this completely: askubuntu.com/questions/221835/… I followed the forum posts and there are several issues already answered in this link, including yours. Remember to do the steps in order. I will not mark this as duplicate because you are in a place where you can either start from the beginning by installing Ubuntu again (Which would mark this as duplicate) or try to solve this specific problem. –  Luis Alvarado Jul 13 at 20:31

6 Answers 6

up vote 1 down vote accepted

Your issue

BootNext: 0009
BootCurrent: 000F
Timeout: 0 seconds
BootOrder: 000F,0008,0009,000A,000B,000C,0007,000D,000E,0001
Boot0001* Windows Boot Manager  HD(3,363800,82000,17b1af25-3a01-4b33-9fa5-e6324bca1b76)File(\EFI\ubuntu\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................

As you have already found out, you probably have a functional entry for \EFI\ubuntu\grubx64.efi that seems to be labelled as Windows Boot Manager, which can be very confusing.

Possible solution

As I don't know of a method to rename these entries I suggest to remove this entry by running the following efibootmgr command:

efibootmgr -B 0001

Where 0001 is the number of the entry to delete and that should be changed according to current efibootmgr output.

To create a new entry run the folllowing command:

efibootmgr -c -d /dev/sdX -p Y -l \EFI\ubuntu\grubx64.efi -L "Ubuntu"
  • /dev/sdX should be changed to the actual device name that contains the Ubuntu partition and the EFI System Partition/ESP (it is recommended to have an ESP for each drive you want to boot from), most likely /dev/sda.
  • Y is the partition number of the ESP, most likely 1.

A possible workaround or recommended fallback could be to set up gummiboot.

share|improve this answer
    
After running these command i get this : pastebin.com/FautmKsz It seems to be good I will try to reboot and use the Windows Boot Manager –  user305139 Jul 14 at 10:44
    
I choose Ubuntu on the Windows Boot Manager but when my computer reboot Windows starting ! I think i should install Grub again ? –  user305139 Jul 14 at 10:51
    
No this command only registeres the bootloader in UEFI NVRAM. For installing grub you should mount the ESP to /boot/efi and run sudo grub-install --boot-directory /boot/efi /dev/sda/. If that still does not give you a bootable Ubuntu installation, then read the troubleshooting section from the link posted earlier in a comment. –  LiveWireBT Jul 14 at 11:04

In nearly every BIOS ever made, there is a little something called boot order. This is still an option in today's UEFI systems. However, GRUB is started as soon as Ubuntu boots, and when you choose Ubuntu in GRUB, it continues the boot process. If you choose Windows, it "redirects" you to the Windows partition and boots. (That is the best way I know how to explain it.) However, if you boot straight to Windows, that means that your system is not attempting to boot Ubuntu at all. There is a simple fix for this. As soon as your computer turns on, press F1, F2, Del, or something similar to access the settings. If you did this correctly, you will see a screen similar to the one displayed below, but every BIOS is accessed and is displayed differently.

BIOS

Navigate to the boot settings. In this example, you should go to the tab labeled "Boot" by pressing the right arrow key four times. Then look for something called "Boot Order" or "Boot Priority". Here is where things get complicated. In BIOS', you would see a list of devices and move them up or down a list. However, in UEFI (which you have and, if you don't know this already, is the same thing as EFI), you would choose from a list of all existing bootable partitions on all detected devices. You want to set the Ubuntu partition to boot first, so, if you're not already, get to the boot order settings and make sure you see a screen like the one displayed below (except the one below was taken in a traditional BIOS, sorry).

BootOrder

Now, let's get some things straight about Secure Boot. Despite what you may have heard, you should keep Secure Boot enabled. Let me tell you how Secure Boot works. Every UEFI system that has support for Secure Boot (basically just about any computer that came with an OEM installation of Windows 8) has a list of keys made into the BIOS. There is almost always a key for Windows, and a key for just about any other major operating system. Unfortunately, Windows is the only major operating system (unless you consider Ubuntu major). Basically, your UEFI needs a key for something before it can boot. That way, if a virus tries to make your computer boot a virus, your UEFI will just say you can't boot from that because you don't have the key. You have to have a corresponding key before something to boot. That's how Secure Boot protects you. However, not every UEFI has a key for Ubuntu. There is no difference in the boot process when you boot from a CD, flash drive, or hard drive. So, if you can boot Ubuntu live fro a CD or flash drive or ran the installation program, your UEFI has the key for Ubuntu and knows that Ubuntu is safe. That means you can leave Secure Boot enabled without problems. Hooray! Also, you need to keep UEFI enabled and never ever set it to Legacy mode or BIOS mode or whatever your UEFI may say. Then, in the list, you should see an option labeled Ubuntu or something similar. Move it to the top of the list, as the list can be rearranged. Save and exit your UEFI, and, if you're lucky, you should see GRUB asking which operating system to boot. Test if the Windows entry works. Then restart your computer and test it again. Then restart and test Ubuntu. Then test Ubuntu again. Test it to your heart's content until you're convinced that it works. Then you're done. If you have any problems, comment and let me know what is happening.

share|improve this answer
1  
If the boot order in UEFI Settings (BIOS) does not give you the ability to select Ubuntu, then efibootmgr will allow you to reorder the boot entries. Put Ubuntu first, before the other entries. –  ubfan1 Jul 13 at 19:43

Get easybcd problem solved i have two Linux OS on my computer with windows 7 http://download.cnet.com/EasyBCD/3000-2094_4-10556865.html

share|improve this answer
1  
Please include complete instructions on how to make Ubuntu boot with UEFI on a preinstalled Windows 8.1. EasyBCD has been suggested many times here to great length, the problem is that this is mostly for legacy/MBR machines or installations, as is the Windows 7 default setup. However the OP asked for UEFI. Please make yourself familiar with UEFI booting. –  LiveWireBT Jul 14 at 5:12
    
I have yet to see a confirmed report of EasyBCD being usable on EFI/UEFI computers. In my own attempts (admittedly a few months ago), it was 100% useless on EFI-based systems, since it set up the Linux entry as if for a BIOS-mode boot, which of course failed miserably. –  Rod Smith Jul 14 at 13:09

Hi and thank you for your anserwers !

@FuzzyToothpaste : I have not found the boot order menu in my BIOS i can just select if I wan't to boot my Hard Drive or my External Drive. I install efibootmgr and I change the boot order (my new order is : 000F,0001,0009,000A,000B,000C,0007,000D,000E,0008) but there is no effect (i don't know if the boot order is correct !) I also enable the secure boot.

@Mew : When i run the command Ubuntu say : error: failed to get canonical path of /cow

I search on Google and i try this : Ask Ubuntu : /cow error (the answer 2). But when i enter "sudo grub-install /dev/sda" ubuntu say that he could not detect the EFI partition !

PS : It's possible ton rename an entry in efibootmgr ? Because if a rename the entry 0001 I can test to boot on it with the Windows EFI boot Manager. Actually i can't because all my entry have the same name and i don't know where is the good entry !

share|improve this answer
    
Please don't use answers unless you are actually answering the question. Edit your question instead while you still have not enough reputation to post comments. –  LiveWireBT Jul 14 at 5:26

I post an answer because i have many things to share !

1 - Thanks to @LiveWireBT i have create a new entry (named Ubuntu) with EFI Boot Manager and i can choose it with the Windows boot Manager. But when i choose Ubuntu my computer didn't want to boot on it. It boot on Windows.

2 - After I use easybcd thanks to @user305306 and i see that Windows 8.1 is the "by default" system. So i change the configuration to get this :

EasyBCD

I reboot my computer and i see a menu who let my choose the system !!! Weepee ! But when i choose Ubuntu i get an error who said that he could not found grubx64.efi. I will post the picture soon !

EDIT : This is the error i get : Error message

In english : The app or system could not be charged because the file is missing or contain errors.

share|improve this answer

I managed to boot to Ubuntu! I realized these steps:

1 - I use efibootmgr as LiveWireBT me advised.

2 - Windows with EasyBCD software I change the status of Ubuntu. I put "System default" and placed first in the list (see screenshot)

3 - I remove all the "Windows Boot Manager" entries EXCEPT Windows 8.1

4 - When I reboot my PC I had access to the Grub and I have chosen as ubuntu system!

Thank you very much to you for your answers!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.