Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've found the way to disable my hybrid card GT 540M on Asus K53SV at: https://launchpad.net/~hybrid-graphics-linux

That's great, but I need those commands to be executed automatically at startup. So I followed the instructions here.

Actually, I copy the bash file instead of creating link in /etc/init.d/

However, it doesn't work at all. My script is:

#!/bin/bash
echo "start my own acpi_call"
cd
cd acpi_call
insmod acpi_call.ko
./test_off.sh
echo "finished.Thank you"

I tried both using "sudo insmod" and "insmod" only but still no effect. What's wrong with it?

share|improve this question
    
Did you read this ? It's a previous post here in AU to run init.d scripts on startup. It says look at man insserv –  nitstorm Jun 21 '11 at 2:12
    
yes. I did. but I didn't know where to put that command "insserv" –  silentbang Jun 21 '11 at 5:31

1 Answer 1

up vote 3 down vote accepted

another option is to install bumblebee and copy the install-files/bumblebee-disablecard-on-powerup into /usr/local/bin with your OFF method.

share|improve this answer
1  
thanks. it works –  silentbang Jun 21 '11 at 5:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.