Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have icedtea6-plugin installed on my Ubuntu box. The weird thing is, when I am browsing the internet, certain websites are able to use Java and some websites don't. For instance, I am able to log in to my bank at ; they use a Java applet to authenticate the user.

But when I try to use; it says Loading Java Applet. And then after a minute or two it says:

Error: Please click here to download Java, If you already have Java, please restart your browser and try again.

I've tried to restart my computer, closed and opened Chromium Browser. But it didn't work also.

Could someone please point me in the right direction to solve this problem?


share|improve this question
Does this happen on any other browser? – RolandiXor Jun 20 '11 at 21:20
See this question maybe you have the same issue : – Binarylife Jun 20 '11 at 21:27
@Roland I have only chromium installed. And this problem definitely exists in chromium. – Jay Jun 20 '11 at 23:53
@binarylife I tried the suggestions on that page. The "Do I have java" link says I do have java albeit an older version. I am using openjdk-6-jre 6b22-1.10. And my "about:plugins" page says that the icedtea-web plugin is enabled. – Jay Jun 20 '11 at 23:57
@Jay I don't think you understood the purpose of my comment :). I want you to tell us if it works on another broswer so we can help to determine what is causing the problem (for example if it is chromium's problem alone). – RolandiXor Jun 21 '11 at 0:54

Try installing the Oracle Java some applications only work with it.

share|improve this answer

keepvid is looking for a plugin that supports application/x-java-jnlp-file. This may be, according to wikipedia, the Java Network Launching Protocol, that is, Java Web Start.

The JWS for IcedTea appears to be provided separately (this is not "java web plugin", it's a different thing Sun once made), in the icedtea-netx package

share|improve this answer

This article is useful if you need help getting the Java plugin work with an Oracle installation: How to install the Java plugin in Ubuntu for Chrome and Firefox

share|improve this answer
Would you mind to explain, why one should follow your link? – user unknown Feb 4 '12 at 2:26

Try installing Java Software Developer Kit (JDK). Look Below Perhaps will work.

share|improve this answer
JDK (Java Developer Kit) is not the same as JRE (Java Runtime Environment). Installing JDK won't make a difference. – Lekensteyn Feb 9 '12 at 20:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.