Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to correctly enable Desktop Cube in Unity 3D?

tried enabling 3d cube in ubuntu 11.04 unity 3d, ha not knowing about the bug, now every time I log into it, it doesn't display anything but the background wallpaper. must help.... ubuntu classic isn't doing it for me.

share|improve this question

marked as duplicate by Jorge Castro, Eliah Kagan, Ringtail, Stephen Myall, Florian Diesch Dec 19 '12 at 10:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

While agree that this question is a possible duplicate of the Reset question, I do have a solution.

  • Log into the recovery console.
  • Run unity & gconf-editor & unity.*
  • In gconf-editor, navigate to /apps/compiz-1/general/screen0/options compiz gconf entry
  • Double click the value "active_plugins".
  • Remove the cube from the list.
  • Close gconf-editor and the terminal window (to logout).
  • Now when you try to log into unity it should work. If it does not, you can try from the first step again, and see if unity gives you any useful errors, leading you to the plugin you need to disable.

* This will start Unity (thus loading that compiz profile just in case), which will fail of course, but then launch the gconf-editor and metacity. It can also give you useful output when unity fails to start.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.