Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed CDT direct by extracting the tar. It detects the other compilers, but fails to recognize mingw32 as a compilation target. Any ideas? Unless you've tried a tutorial and it recognizes properly, please no links to the first 5 google results...I tried them.

By the way, I'm on 10.04 LTS. The same situation occurs on 11.04 and 11.10.

share|improve this question
my hackish fix at the moment is to have a shellscript rename gcc to gcc-native and the mingw binary to gcc. this is a stop-gap hack NOT a solution. if somebody has a real fix, I'm open to suggestions. – RobotHumans Jun 22 '11 at 2:01
If anyone comes up with a better solution, let me know and I'll change the accepted answer to yours – RobotHumans Mar 26 '12 at 18:06
up vote 2 down vote accepted

While this guide targets wxwidgets, it's the best answer I could find. Also, it targets windows, but the theory remains the same.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.