Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I turned on my PC the other day, and it wouldn't turn on. After a lot of messing around with grub and liveCDs, I found out the problem was in my 2nd hard drive (500GB, SATA connected, used to be sdb1) and that it was "not ready". I commented it out of fstab, and I managed to get Ubuntu to boot. However, I can only get into the guest account because my home folder was on the 2nd HDD. On top of that, Dist Util doesn't show it (there's only 1 HDD there) and sdb1 has disappeared from /dev (sdb is still there though). I can't figure out how to mount this thing, or how to fix it...

Any help would be great. Thanks guys!

Update: Well, this is embarrassing. I went to connect a CD drive (So I can boot a LiveCD again) and, uh, the SATA cable for the 2nd HDD had fallen out. 0_o

But now, I'm still stuck: I can't mount it as guest, and I definable can't change fstab back. Any ideas? Maybe if I could get back to that console it opened when it was broken...

Update 2: Mkay.

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
none on /tmp/guest-1hN2ss type tmpfs (rw,mode=700)
/dev/sdb1 on /media/Stuff_ type ext4 (rw,nosuid,nodev,uhelper=udisks)

Look, I feel I need to clarify this. The admin account is inaccessible due to it being on the second hard drive, which is inaccesible on login due to it being commented out of fstab. The only account is the guest account, which cannot access/change fstab. I mounted the 2nd HDD via the file manager, but "Error opening directory '/media/Stuff_': Permission denied". I need to edit fstab in order to add the 2nd HDD back in.

share|improve this question
    
Does Gparted shows it? Is it in /dev/sdb still? –  Ruslan Gerasimov Jul 13 at 1:57
    
Now it does. ;P –  Quark Jul 13 at 22:15
    
So now what is really your question? What would you like to achieve with it? –  Ruslan Gerasimov Jul 13 at 22:21
    
Sorry. I kinda edited the original post. I thought you'd notice. Basically, I found the dive wasn't plugged in (facepalm) but now I'm stuck with it - I can't mount it as guest, and I commented it out of fstab during my repair efforts. I can't get into an admin account (It was on the drive) and now I'm stuck. –  Quark Jul 13 at 22:28
    
I did not get why you need to get back to "that console". If you're missing it in fstab so it is kind of /dev/hdb1 /home ext4 defaults 1 1 or UUID=680778ec-f545-4c12-a8b5-1a03e6287fa6 /home ext4 errors=remount-ro 0 2 (but get your UUID for that drive by sudo blkid) –  Ruslan Gerasimov Jul 13 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.