Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did the HWE upgrade and that worked fine. System started fine. But I ran Ubuntu Tweak and it reported massive amounts of cruft. So I did the Janitor and uh-oh...system boots to command line terminal. After research I figured out that lightdm was not starting and got the desktop back by installing and switching to gdm. I'd like to understand the problem and get lightdm back but a day of effort has not rewarded me with success.

I am running this system as a headless box, it has no proprietary drivers.

My goal is to regain lightdm, can anyone suggest an approach?

Here is my lightdm log:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log

[+0.00s] DEBUG: Starting Light Display Manager 1.2.3, UID=0 PID=1744

[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf

[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager

[+0.00s] DEBUG: Registered seat module xlocal

[+0.00s] DEBUG: Registered seat module xremote

[+0.00s] DEBUG: Adding default seat

[+0.00s] DEBUG: Starting seat

[+0.00s] DEBUG: Starting new display for automatic login as user bill

[+0.00s] DEBUG: Starting local X display

[+0.00s] DEBUG: Using VT 7

[+0.00s] DEBUG: Activating VT 7

[+0.10s] DEBUG: Logging to /var/log/lightdm/x-0.log

[+0.11s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0

[+0.11s] DEBUG: Launching X Server

[+0.11s] DEBUG: Launching process 1749: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

[+0.11s] DEBUG: Waiting for ready signal from X server :0

[+0.12s] DEBUG: Acquired bus name org.freedesktop.DisplayManager

[+0.12s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0

[+0.12s] DEBUG: Process 1749 exited with return value 1

[+0.12s] DEBUG: X server stopped

[+0.12s] DEBUG: Removing X server authority /var/run/lightdm/root/:0

[+0.12s] DEBUG: Releasing VT 7

[+0.12s] DEBUG: Display server stopped

[+0.12s] DEBUG: Stopping display

[+0.12s] DEBUG: Display stopped

[+0.12s] DEBUG: Stopping X local seat, failed to start a display

[+0.12s] DEBUG: Stopping seat

[+[+1057.81s] DEBUG: Got signal 15 from process 1

[+1057.81s] DEBUG: Caught Terminated signal, shutting down

[+1057.81s] DEBUG: Stopping display manager

[+1057.81s] DEBUG: Display manager stopped

[+1057.81s] DEBUG: Stopping daemon

[+1057.82s] DEBUG: Exiting with return value 0

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Fortunately I had a working system to compare it to. Ubuntu Tweak for some reason deleted a symlink in /etc/X11 and this caused lightdm to fail.

The fix is easy:

cd /etc/X11
sudo ln -s /usr/bin/Xorg X

and Bob's yer uncle.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.