Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed a pre-made Ubuntu 10.04 image at work, and I can't seem to figure out how to get desktop switching to work. No shortcuts work, and all the help I can get from the Ubuntu forums is "CTRL-Alt-Left/Right should work."

So let me get this straight. Switching between desktops is deprecated, so we use viewports, which are managed by Compiz, which has one of the most absurd configuration managers out there. Lovely.

Can anyone straighten this out for me, and anyone else who might stumble on this question?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Have you tried setting them in the keyboard shortcuts? Seems to work fine over here:

enter image description here

(You can click on the shortcut field for each function and then the tool will prompt you to set a shortcut)

share|improve this answer
    
I don't see any of those fields in my Keyboard Shortcuts... –  Alex Jun 20 '11 at 16:05
    
@Alex Can you update your question with a screenshot of what your keyboard shortcuts does look like? –  Jorge Castro Jun 20 '11 at 16:06
add comment

Note: I'm using 11, so the details may differ a little.

You'll need to install Advanced Desktop Effects Settings (ccsm) if it isn't already, and run it.

Under Desktop Wall click on the Bindings tab.

Under Move within wall for Move Left, Move Right ,etc click the first button on the right (it will say Disabled or give a key combination).

Select Enabled and click Grab key combination

Press the keys you want to use for the shortcut.

Desktop Wall - Bindings

I have the same config as Jorge Castro so I don't think the Gnome and Compiz settings will conflict.

share|improve this answer
add comment

I recommend asking whoever pre-made that image for you, if none of the other answers work as expected. It could be that there's some obscure, custom setting that your image has that changes the default behaviour.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.