Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I put file icon.png in to the usr/share/icons folder (doing that as root), I can't set that icon on my application latter on. When I try, I navigate to the icons folder, but that icon doesn't work. I can't even see it by navigating to icons folder one more time. I can see it or only open it when I go to the icons folder with root privileges.

This happens on Linux Mint 17, 32 bit.

Enter image description here

As you can see, while in regular mode, I can't see the picture, and while in root mode, I can edit it, so how could I be able to set it as my application icon?

share|improve this question

closed as off-topic by Sylvain Pineau, Braiam, chaskes, karel, Radu Rădeanu Jul 13 at 9:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Sylvain Pineau, Braiam, chaskes, karel, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
i think this site is only for ubuntu users –  agha rehan abbas Jul 12 at 11:07
1  
@agharehanabbas - it is - close voters bear in mind the icon system will work almost exactly the same on many Linux systems.... –  Wilf Jul 12 at 12:54

2 Answers 2

up vote 2 down vote accepted

It might be related to permission problem in your png file

try this sudo chmod 644 /usr/share/icons/mcicon.png

For more info about permissions :

http://gd.tuwien.ac.at/linuxcommand.org/lts0070.html

share|improve this answer
    
thank you! it worked!! –  Eimis Jul 12 at 13:03

You likely have two problems here

  • Permissions

    You can do this in Nemo by right-clicking on the file, going to Properties and setting it so the file can be read by 'Other' users.

  • Where you put it

    The icon directories sort of work like this (as far as I remember):

     /usr/share/icons/ICON-THEME/RESOLUTION/TYPE/ICON
    

    e.g.

     /usr/share/icons/gnome/16x16/places/user-home.png
    

    So you need to resize your icon to the correct resolutions (48x48/64x64 is usually enough), then place it in the correct location (probably the apps folderin thegnomeorhicolor` folder.) - e.g.

     /usr/share/icons/hicolor/48x48/apps/mcicon.png
    

    Possibly better method include editing the .desktop launcher file of the app to have the correct icon path:

      Icon=/usr/share/icons/mcicon.png
    

    And to put any changes you make in your user's home directory e.g. for launchers, in ~/.local/share/applications (I think for icons it is ~/.local/share/icons)

Most of this is off the top of my head as I don't have access to a Linux box at the moment... :(

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.