Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue where I am creating .cap files with aircrack-ng and am saving them to the desktop, but I can't see them. When I use the ls command in the terminal they show up, but just not on the graphical desktop view. I want to be able to see them on the desktop and not just through the terminal. Any help would be appreciated, thanks!

EDIT: Turns out I am not saving them to the desktop, but rather the /home/user/ directory. The hidden files show up when I press CTR + H, but they don't show up in the terminal; the only file showing up in the terminal when I use the ls command is the desktop (sorry for the topic edit). How can I get the hidden files to show up in the terminal as well?

share|improve this question
1  
What is your file manager? –  kenn Jul 12 at 10:15
    
What is the output of ls -al ~/Desktop? (Please edit it into your question) –  Wilf Jul 12 at 10:26
    
please post your ls list screen shot and your file manager –  Sudheer Jul 12 at 11:47
    
I wish there was a way to accept two answers because I asked two questions :/. –  Seth Taddiken Jul 12 at 11:57

2 Answers 2

up vote 2 down vote accepted

Files that start with a . are hidden from the graphical interface.

To view them, just open up your file browser and go to 'Edit'->'Preferences' and check 'Show hidden files and backup files'.

You can also toggle the hidden files using Ctrl+H

EDIT:

To get the hidden files to show up in terminal, use:

cd
ls -al

cd takes you back to your home folder while ls -al lists (the -l flag) all files (the -a flag) hidden or not.

share|improve this answer
1  
Thank you for this information! It solved one of my two issues, my new one now edited to the same post. I would give this answer a plus if I could, but I don't have 15 reputation yet haha. –  Seth Taddiken Jul 12 at 11:50

To view files list use ls command. To view hidden files as well use ls -a or la commands.

Hidden files will have . before them.

Eg: you should use ls /home/user/ and for hidden files la /home/user/ for list view ls -al /home/user/

share|improve this answer
    
Although la doesn't work, ls -a does. This may be because this is an Ubuntu focused site and I'm using Kali Linux, but I don't know for sure. Thank you very much! This completes the second part of the answer to my questions :). –  Seth Taddiken Jul 12 at 11:55
    
ls ~ is the same as ls /home/USER by the way –  Wilf Jul 12 at 12:42
    
yes its the same. –  Sudheer Jul 12 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.