Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What is the planned status of Multiarch support in 11.10? In AMD64 Alpha 1, I attempted to install the i386 google chrome package using dpkg. The install failed citing architecture mismatches, Is support for this kind of install planned or am I missing something?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Install 32-bit Compatibility Libraries

Have you tried installing the 32-bit libraries?

sudo apt-get install ia32-libs

If that's installed, then navigate to the Chrome .deb package and use (to force installation):

sudo dpkg --force-architecture -i <name-of-package>.deb

And if things aren't working at first, try re-configuring the package manager:

sudo apt-get install -f

Or...

sudo dpkg --configure -a

Download Native 64-bit Google Chrome

Alternatively, you can just install the native 64-bit Chrome package from here at Google.

Just remember that Oneiric is still in Alpha, many things can go wrong; don't be surprised if it doesn't work initially!

Reference:

Ubuntu Forums

share|improve this answer
    
Thanks for the dpkg info, I need to use a 32-bit browser to support the Juniper VPN which only works with a 32 bit browser/plugin –  Mark Bidewell Jun 20 '11 at 14:48
    
@Mark, glad to help. And as Jorge posted, Multi-arch will appear natively (hopefully soon) instead of through abstraction libraries. Sorry, I missed that bit of the question :S –  Alex Stevens Jun 20 '11 at 23:05

The plans for multiarch support in Oneiric are here:

(It could likely be broken in the Alpha)

share|improve this answer

Multiarch is supported pretty well at this point (last time I tried was Beta 1). It's just that a package must be build with support for Multiarch. You can see whether a package was built for Multiarch by checking it dependencies for the multiarch-support package.

For a more in-depth answer on Multiarch, see Is it possible to have 32 bit libraries installed on a 64 bit system (for pogoplug)

share|improve this answer

When I updated to Oneiric, I lost the ability to exec 32 bit bins. I was able to find the ia32-libs-multiarch package, which was what ultimately got me back and running.

Curiously, aptitude install ia32-libs-multiarch led to some grotesque and unexpected dependency issues (particularly, it broke on libmysqlclient16.) Using the old apt-get did the trick, however.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.