Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched from Qwerty to Dvorak, but the login screen still uses Qwerty.

How can I configure the login screen to use Dvorak?

share|improve this question

1 Answer 1

up vote 10 down vote accepted

In Ubuntu / Natty, edit the file /etc/default/keyboard, look for the XKBVARIANT setting, and set it to this:

XKBVARIANT="dvorak"

This will tell GDM, the login manager, which keyboard layout to use per default.

Note: the comments in the file warn that this only takes effect after udev is restarted; I would just reboot the machine after changing it.

share|improve this answer
    
This helped me with another problem. While I kept removing the Qwerty keyboard from my keyboard preferences, after I rebooted it always showed up again. I then removed it from the /etc/default/keyboard file as you said and I now no longer have the problem. –  snth Aug 7 '11 at 12:39
    
I can confirm this still works on Trusty. In fact it seems to be the only way to change the login screen keyboard layout. –  poolie May 20 at 4:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.