Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently I am running Windows 7 on my PC. When I boot to Windows, it connects to the internet.

But when I try to install Ubuntu 12.04 and boot from the flash it shows Disconnected - You are now offline.

I am using wireless internet, and I also tried connecting directly from my router to my PC too, still I cannot connect to the internet.

Anyone has an idea how fix this very annoying problem?

the output of ifconfig is as bellow:

    eth0      Link encap:Ethernet  HWaddr 62:d5:10:5d:82:31  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1312 (1.3 KB)  TX bytes:1312 (1.3 KB)
share|improve this question
    
We are going to need some more details to help you. Do you use a proxy when in windows? Make and model of computer, Plug in a LAN cable open a terminal by pressing CTRL + ALT + T and enter lspci; ifconfig copy all the output and edit your question to include it. –  Warren Hill Jul 11 at 11:58
    
Do you see available networks or not ? And what happens if you run this: sudo /etc/init.d/networking restart ? –  begueradj Jul 11 at 12:50

2 Answers 2

I had the same problem with my hp dv6. After a lot of playing around with things and making sure the right drivers were installed, I tried checking my Bios settings and reset to default. Apparently that did the trick for me I guess when they install windows on laptops it changes something in the Bios.

share|improve this answer
    
my labtop is also hp dv6 –  ghazaleh Jul 11 at 13:31
    
Have you tried my suggestion? when you boot up the computer keep hitting the esc button till it gives you a menu. When the menu is up hit F10 i believe to enter the bios menu. Then restore to default save and exit. –  Ripndip Jul 11 at 13:58
    
I did what you said but nothing was change, should I update my bios??? –  ghazaleh Jul 11 at 14:37
    
I have the latest bios from HP. –  Ripndip Jul 11 at 15:41
    
I updated my bios to the latest version, but still I couldn't connect to the internet –  ghazaleh Jul 12 at 5:53

Try connecting to the internet directly with an ethernet cable, not through the router. Just disconnect your router from the internet and plug the cable into your computer. Does it work? If it doesn't then there's a problem with the network-manager package.

I suggest to make the flash drive bootable again. Or you can install Ubuntu without connecting to the internet. You can connect later, after the installation. Let me know if it worked. If not i can help you fix your network-manager package

share|improve this answer
    
I inistall the ubuntu without connecting to the internet, but I still have problem to connect to the internet. what should i do now? –  ghazaleh Jul 11 at 14:02
    
Ok, then you need to reinstall your network manager. This would be really easy if you had internet, but without internet things get a little bit more complicated. Follow the steps in the second answer to this post: askubuntu.com/questions/422928/… Make sure to select the network manager package that corresponds to your version of Ubuntu. Good luck :D –  user301571 Jul 23 at 23:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.