Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a Dell Latitude D820 and a fresh / clean install of Ubuntu 11.04 x64. My graphics card is detected as nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (it's the NVS 110M - the Go is the non-OEM version I believe). I'm running the recommended drivers from the Additional Drivers dialog.

I have tried running compiz --replace and unity --reset, but both commands hang my laptop.

I'm not really sure what other information I need to provide, so please let me know.

One more thing. When I run compiz --replace, it freezes on "starting unity-window-decorator"

Many thanks!

edit: compiz is not running, and I do have the compiz config manager installed.

when I run CCSM from terminal this is the output I get. Does anyone know what those errors mean? http://pastebin.com/2WJzw3ZU

note, this dump is from "Ubuntu Classic"; I get something similar if I run in Unity mode, but the profile says Unity.

I should also say that it looks like Unity will load, but will hang up the display after. For example, I'll see the drop shadows on the windows, the cursor will change if I'm hovering over a window border or something, but nothing on the UI will update. I can manage to click on my Terminal shortcut and type sudo reboot and it will reboot, so it's just the GUI that's crashing.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

I don't know about Quadro NVS 110M, but GeForce Go 7300/7400 are known to have problem with Compiz/Unity in 11.04. The crash/freeze/no-feedback happens with the recommended proprietary (nvidia-current) driver installed, but nvidia-173, a legacy driver works well, at least for some. There are multiple bug reports on launchpad.net, but no fix yet. https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/728745

In short, it you want to run Compiz/Unity, try removing nvidia-current and install nvidia-173.

share|improve this answer
add comment

Some things you can try
'Start' menu->System->Administration->Additional Drivers-> Recommended NVIDIA drivers , or try version 173.

run ccsm under 'Effects' -> 'Window Decoration' -> 'General' -> 'Command' ->
Change this to blank, or 'gtk-window-decorator --replace', or 'kde4-window-decorator --replace', or 'emerald --replace' depending on which window decorator you prefer.

Note: I have Dell Latitude D830 NVS 140M, and Compiz 0.9.2.1* works here on Ubuntu 11.04, 64 bit, not really a fan of Unity though, running without it.

*didn't like the Ubuntu one, nor the latest git, you might like the latest 0.8.x version
(note: this removes unity)
http://www.webupd8.org/2011/05/how-to-downgrade-to-compiz-086-in.html

share|improve this answer
add comment

I also own a D820 with the same gpu, so I have some experience with this issue. Be warned, the graphics card gets pretty hot and the performance might lag. Anyway...

If you want to force Unity 3D Mode, open a terminal console and type in

sudo gedit /etc/environment

add the following line at the end

UNITY_FORCE_START=1

save, exit gedit and reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.