Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu installed in my laptop, with Catalan language support and I have properly set up my keyboard to the Spanish layout. However, every time I start Ubuntu, the keyboard language/layout has switched to English (I think) and I have to select the correct disposition again ("Es"). The tray icon, though, always shows "Es" as the input language, which, by the way, is the only option available.

Is there a way to tell Ubuntu to properly configure the keyboard?

Edit: Once I login, I always change the language using the top-left button on the tray (see the "[Es]" icon in the picture below:)

The tray icons where the "Es" icon displays the keyboard language settings

share|improve this question
    
Can you please describe how you did when you set the Spanish layout? Are you talking about the login screen or within a session (or both)? –  Gunnar Hjalmarsson Jul 10 at 13:21
    
I edited the question with more information. I always use the graphic-based language settings menu. –  Carles Araguz Jul 10 at 16:40

2 Answers 2

up vote 0 down vote accepted

I have an idea that may appear somewhat counterintuitive...

Open the Text Entry window and add English (US) to the list of input sources, while keeping Spanish at the top of the list. That's how I have it setup myself (even if I have Swedish instead of Spanish) and it usually works fine.

share|improve this answer
    
I'm still not sure whether your solution really solved the issue, because when I tried to do what you suggest I also installed additional language packages. Anyway, now it's solved, so thanks a lot! –  Carles Araguz Jul 16 at 8:48

Starting from the first boot after a successfull Ubuntu installation the typical scenario, according to my experience, is:

  • you get the US/American language for the UI, for the input you get the keyboard layout according to your locale
    • if Ubuntu can't determine your locale the fallback is on the US keyboard everytime
  • after the first boot you have to download and update all the language packs for all the software that you have, this way you get to complete the setup for the language for your specific locale for both the interface and input.

You can always enable and disable more than 1 option for the keyboard layout, after downloading and installing all the language packs I tipically go into the setting panel and make sure that all the keyboard layouts are disabled except the one I'm interested in. The little icon with the locale in the upper right corner of your desktop should contain a shortcut to the settings anyway.

share|improve this answer
    
I tried your solution and at the beginning I thought it solved the issue. However, after a few reboots, the problem appeared again, so I tried what @Gunnar-Hjalmarsson suggested and now it's all (surprisingly) working properly. Thaks a lot for your help, though! –  Carles Araguz Jul 16 at 8:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.